1. Bill1975's Avatar
    I have an iPhone 3G, iOS4.1, jailbroken with Redsn0w

    Recently, I updated to iOS 4.1 from 4.0.1, and then rejailbroke with the latest version of Redsn0w. Soon after, I noticed the following:

    1) Maps, and Foursquare (both use GPS) could not locate my location, and therefore didn't work properly.

    2)When closing either of those apps, the "arrow" icon in the status bar did not disappear, as it should when the app closes. A quick look at SbSettings confirmed that those apps were not running in the background.

    3)When I tried to either reboot, or respring, the phone would freeze on the lockscreen. It would try and reboot/respring, but would again get stuck on the lockscreen. After forcing the phone to turn off, the phone would reboot, and then get stuck on the lockscreen again. The "spinning wheel" popped up after this, which suggested the phone was trying to do something, but was unable to. It took 3 failed attempts to get the phone to finally boot properly.

    4) If I tried to shut down by holding the sleep button, it worked fine.

    I do not know if problems 1 and 2 are related to problem 3.

    After the initial upgrade to 4.1, I noticed there were some duplicate directories in /var/stash. I tried deleting some manually, and thought that was the root cause. However, after restoring and rejailbreaking, I noticed the duplicate directories were gone and everything looked fine. I assumed this would fix it, but it has still shown some of those symptoms, but not as regularly before. Sometimes everything functions fine, sometimes I have the same problems.
    2010-11-09 12:12 AM
  2. Bill1975's Avatar
    Could this just be a conflict with the jailbreak?
    2010-11-10 05:33 PM
  3. Bill1975's Avatar
    I reinstalled Winterboard and a theme today, and the phone started exhibiting the same behavior again. In addition the settings app wouldn't load.

    Any ideas?
    2010-11-11 08:59 PM
  4. Bill1975's Avatar
    I removed winterboard and its behaving a little better, yet settings still wont load. I would really appreciate any advice that anyone has. If not, is there another forum or resource I can look to for help in tracking down the root cause of my issue?
    2010-11-15 02:02 AM
LINK TO POST COPIED TO CLIPBOARD