1. torndownunit's Avatar
    I know there are other threads on this topic, but none of them seem to address my exact issue.

    I am running an iPhone 4 with 4.2.1 that I recently JB'd. Everything is working fine but Safari.

    - It won't start, appears to be frozen
    - All icons are greyed out except the bookmark menu and the new window button. But, I can't press those
    - can't input anything in search or address bar
    - "+" button appears to be missing
    - it will quit if left open for about 10 seconds

    - I have cleared history, cookies, cache
    - Done reset

    - As far as I know I don't have Safari Download Manager installed. I didn't install it, and I don't see the icon for it that you see in some youtube videos.

    Does anyone have ANY other suggestions to try?

    Right now I am just running Atomic which works fine. I just don't like having a function completely broken on my iPhone, and I do like Safari for some things.

    Thanks for any suggestions.
    2011-02-17 02:59 PM
  2. Simon's Avatar
    2011-02-17 03:22 PM
  3. torndownunit's Avatar
    What did you jailbreak with?
    Hi, latest Greenpois0n.

    I haven't installed many packages yet. SBS Settings, Lockinfo, bite SMS. Same things I had when I was running 4.01 Jailbroken for the last year or so.

    Adblocker is installed but I shut it off because I wasn't sure if it was reacting with Safari in any way.

    If there is anything else I should be mentioning let me know. I don't know what info is needed.
    2011-02-17 03:45 PM
  4. Simon's Avatar
    It sounds like something you installed in cydia is the culprit. Was it working fine after you jailbroke but before you started installing stuff?
    2011-02-17 03:46 PM
  5. torndownunit's Avatar
    It sounds like something you installed in cydia is the culprit. Was it working fine after you jailbroke but before you started installing stuff?
    Ya it was. Is there a way I can ouput a list of what I installed with Cydia or display it on the phone somehow? I think I listed everything above, but maybe I was trying an app out and some point and forgot about it...
    2011-02-17 03:58 PM
  6. Simon's Avatar
    You can see what apps/tweaks you have installed under the manage tab in cydia.
    2011-02-17 04:10 PM
  7. torndownunit's Avatar
    Thanks for the help. I guess I will start with uninstalling Cydia apps to see what happens. I just hope I don't have to restore and Jailbreak again. I just got everything up and running great after being on 4.0.1 since it came out. I don't want to start all over lol.

    I guess there is no way to just reinstall Safari on it's own?
    2011-02-17 04:39 PM
  8. Simon's Avatar
    2011-02-17 06:02 PM
  9. Doneok's Avatar
    Hey, I need your help aswell... My iPod in version 4.3.3 and I jailbroke mine with redsn0w... PLEASE HELP!! im having the EXACT same problems as the ones described above! Plz reply quick! Thankyou
    2011-05-24 03:56 AM
  10. Shady1213's Avatar
    It's ad-blocker , turn it off or remove it and it should be fixed
    2011-05-24 07:30 PM
LINK TO POST COPIED TO CLIPBOARD