User Tag List

  1. SJLY's Avatar
    Hello all & sundry,

    I am new here (although I've been lurking for a while). Last week, I backed up my 64 GB iPod Touch 4G (iOS 4.2.1) to iTunes, saved my SHSH blob(s) using TinyUmbrella, and then successfully jailbroke said iPod using greenpois0n. This was my first JB. I've been hesitating for ages : all the panic-stricken horror story posts made me apprehensive, but it went smooth as cream. The excellent guides & tidbits posted here (& elsewhere), made the process vastly simpler than anticipated. Thank you, everyone collectively, you are the cat's @ss!

    Since then, I've installed Winterboard & a few other Cydia apps, & then played/made some mods (first by using iPhone Explorer, Phone Disk, & DropBox to move files back & forth don't ask). A few days ago, I finally clued in & added iFile, OpenSSH, & then (via iFile) MobileTerminal vers. 520.1 (&, yes, I changed the password from "alpine"). So far, so good.

    So, here is my issue : this morning I turned on my pwnedPod & noticed that I had an app store update pending. I attempted to download it &, after an odd delay, was informed that the "update will be available for download when you log into the iTunes Store on your computer". Weird. I also tried downloading an app from the app store & received almost exactly the same message.

    Now, this wouldn't be a problem except for the fact that, in a moment of truly epic stupidity, I upgraded iTunes to 4.3 Note to self : think before you click "Update". (Go ahead: laugh I would). Hence, although I downloaded both the update & the app I wanted on iTunes, I sure as heck cannot sync my iPod.

    At the moment, I am attempting to transfer the app to my iPod from my MacBook (OS X 10.6.6; I'm using Cyberduck). However, I am starting to wonder if this is possible because, on my iPod (under /User/Applications), each app is in a file bearing a unique alphanumeric code. Obviously, just dropping in the file doesn't work. I confess that I'm at a bit of a loss.

    Is it possible for me to transfer an app store app from my MacBook to my iPod without using iTunes? Or will I need to either : i) wait for the untethered 4.3 JB or ii) sync, transfer the apps, downgrade using the SHSH blob, & re-JB? Any feedback, suggestions, advice &/or random catcalls from the peanut gallery would be greatly appreciated.

    Thanks!

    SJLY

    I just realized that my 5th paragraph is ambiguous (bear with me; as I indicated, I've only been at this for approx. a week). Let me take another kick at the can ...

    In my initial attempts to transfer the app ("Chaucer.ipa") from my iTunes library, to my iPod, bypassing the iTunes interface, I tried to use iPhone Explorer and/or Phone Disk. Earlier, I had successfully used one or the other to switch the icons for the built-in apps to icons I had designed myself in Pixelmator. Yet when I attempted to simply copy or move the app from my library to the iPod (like I had moved the icons), it didn't work : all the other apps on my iPod occupy individual file folders, whereas Chaucer.ipa does not. I need to do something other than just copy it to the iPod via one of the aforementioned programs.

    It was here that I decided to try
    Cyberduck/OpenSSH. Making the connection & navigating posed no difficulties. As mentioned in my previous post, however, each app (under /User/Applications) is, again, in a file folder --- but this time, each folder is named with a unique alphanumeric code (rather than the name of the app). Again, I cannot simply drop in Chaucer.ipa; clearly something else needs to happen here. But what?

    I suspect that I'm missing something extremely obvious, but I'm not clear on what that might be. Contrarywise, maybe one simply cannot move App Store apps in this fashion. Would someone please clarify this for me?

    Thank you


    (I hope this is a smidgen clearer. If any extra info., would help, let me know).
    Last edited by SJLY; 2011-03-06 at 03:25 AM. Reason: Automerged Doublepost
    2011-03-06 03:25 AM
  2. SJLY's Avatar
    Rather stupidly, it only just occurs to me that I cannot have updated iOS since 4.3 hasn't been released yet. Rather, iTunes updated. Immediately thereafter I found I couldn't update/download from the app store on my iPod, hence I grew confused & conflated the two.

    I realize that this sounds absurdly self-evident to everyone here. It's also probably why I haven't received a reply : the question makes no sense! While I am not stupid, I am definitely not a tech person. It was an honest error.

    [Oh well; if nothing else, I've made you all laugh! To my mind, that's a worthwhile outcome : given the state of the world just now, we could all use a little more comic relief ].

    However, I am still not clear on whether this (sc., updating iTunes) matters in practical terms.
    Again, this may be a bizarre question, but : Does the iTunes version matter? Can I sync, then? (i.e., without needing to re-JB). Or no? If I can, then "great!" No response to my initial question is needed.

    It seems that it shouldn't matter, but if it does not, then why am I unable to update or download from the app store on my iPod since these changes? I haven't seen references to the latter phenomenon anywhere. Are the two related at all? Or could it be something else? Has anyone else experienced this?

    To paraphrase Fermi, before I came here I was confused; now I am still confused, but on a slightly higher level.
    "It is the first responsibility of every citizen to question authority".
    Benjamin Franklin (17061790)
    2011-03-07 11:25 AM
LINK TO POST COPIED TO CLIPBOARD