1. thekeem's Avatar
    Hi all,

    New user here, I would appreciate your quick responses as i'm abstaining from locking or resetting my iphone

    I followed a quick and supposedly simple tutorial to fix term-vt100 on my 1.1.3 firmware:

    http://jmoz.co.uk/blog/iphone-113-te.../6#comment-133

    at the very end while trying to adjust permissions (last step of the tutorial) i was provided with this message:

    # chmod +s /Applications/Term-vt100.app/Term-vt100
    dyld: Library not loaded: /usr/local/arm-apple-darwin/lib/libgcc_s.1.dylib
    Referenced from: /bin/chmod
    Reason: no suitable image found. Did find:
    /usr/local/arm-apple-darwin/lib/libgcc_s.1.dylib: stat() failed with errno=62
    /usr/lib/libgcc_s.1.dylib: stat() failed with errno=62
    zsh: trace trap chmod +s /Applications/Term-vt100.app/Term-vt100

    It is worth noting that before performing a chmod to this directory i attempted to do it to /private/var/root/Applications/Term-vt100.app/Term-vt100 where the actual application lies (the other is a link) and i was provided with the same message.

    Now no apps except for installer and phone will load, what can i do?

    Update:

    i tried to download the entire lib directory over FTP and it gets to the libgcc_s.1.dylib file and gives me an error that it cannot download it (remote stat failed), but i can check info on the symlink which says the permissions are 755 (should they be?)

    Has the original file been deleted? Help, please someone i dont want to have to restore the FW and jailbreak again

    FINAL UPDATE (Solved):

    Just writing this because i read that other people had this problem too.

    First off, if this happens to you, do not under any circumstance reboot your iPhone otherwise you WILL have to recover it and re-jailbreak

    It turns out that the symlink deleted the original libgcc_s.1.dylib file in /usr/lib, so what i did was took the (similar) libgcc_s_v6.1.dylib and duplicated it, renaming it to libgcc_s.1.dylib and replaced the symlink with it, now everything works as usual.
    Last edited by thekeem; 2008-03-19 at 10:32 PM. Reason: Update
    2008-03-19 10:12 PM
LINK TO POST COPIED TO CLIPBOARD