User Tag List

  1. only1pj's Avatar
    I recently updated my iPhone 4 to 4.3.1 (bb 04.10.01) and jailbroke it with redsn0w 0.9.6rc6. No unlock as its a TESCO (o2-UK) contract

    I backed up the device first using itunes, updated it and restored the backup after jailbreaking it.

    I had major problems at first syncing the apps I had downloaded from the app store and even resorted to emailing itunes "support" for ideas, needless to say I neglected to tell them about the jailbreak.

    I was constantly getting error 0xE800801c while trying to sync. I restored a few times and swapped round the jailbreak and backup restore to see if that made a difference. It didnt.

    I eventually got the phone to sync no problem on my laptop so I thought all was well. I had to re-download a bunch of apps but at least they were syncing.

    I eventually found that there were a shed load of applications missing from the iOS Settings menu. I have about 48 apps on the phone at the moment and only six listed under settings. Namely Angry Birds, Cineworld, Facebook, ibooks, nike+iPod and red laser. Im missing options for twitter, ebay, micoach, lovefilm, F1 Live24, shazam, genius scan+, dragon dictation, viber and loads more.

    I have looked through the forums and on google and the best answer people can come up with is "do a restore". Well as I mentioned, ive done that a few times and im running out of ideas. There are a few posts recommending the removal of things like extended preferences ( http://modmyi.com/forums/unlocking-a...-settings.html ) but I dont ever remember installing it.

    The images below were an attempt to try and find where two apps were listed on the iphone, although it iFunbox doesnt seem to search inside files. I was hoping that I might find one of the missing apps in one place and missing from another - at least then I could give a bit more info on a forum - but one of the missing apps, viber, is listed in more locations that the other.

    Any suggestions on why the applications are missing only from the settings menu, yet are installed and working fine?

    What causes the 0xE800801c error? I read a lot of posts here stating "I know, but tell me where you got the apps" - They are all "legal" and downloaded from the device or itunes app store.

    Where to look for the actual preferences / settings app/folder that I see from the iOS, OR which file/folder is used to generate the viewable list in the settings menu?



    Thanks!
    Peter



    2011-04-25 02:19 PM
  2. mado309's Avatar
    Hey bro just restart in safe mode from sbs menue everything will show change what you want then exit safe mode. Let me know if that works
    2011-04-26 03:41 AM
  3. only1pj's Avatar
    Mado,
    Thanks for the reply!

    I just tried "Safe Mode Launcher" from Cydia to reboot in to safe mode, then re-read what you wrote! Installed SBSettings and eventually found the Safe Mode option under Power in SBSettings. Both Safe Mode Launcher and the option in SBSettings restarted the device with the words "it Safe Mode" at the top of the screen where the time usually lives. it safe mode???. In both attempts there were no new options available in the settings menu.

    The image below shows my settings menu.

    2011-04-26 01:09 PM
  4. A3gOwner's Avatar
    Not all apps have options under settings. Just certain ones. I've got close to a hundred apps and only nine show in settings.
    2011-04-26 03:20 PM
  5. only1pj's Avatar
    Thanks for the reply!
    I know a lot of apps wont have settings and to be honest Im not sure, because of the problem im having, which do and which dont.

    I know Viber should have options under the settings menu and IMDb... if anyone can say yes or no these should or should have settings I guess that might help work out what I am missing?!

    Splice
    facebook
    twitter
    pingchat
    modmyi
    light
    natwest
    onthego (first direct)
    paypal
    angry birds
    bubble explode
    solitare
    ebay
    selling (ebay)
    cineworld
    lovefilm
    miCoach
    f1 Live24
    imdb - yes
    kindle
    audiobooks
    genius scan
    dictation (dragon)
    fotonote
    vlingo
    box.net
    dropbox
    evernote
    translate (google)
    shopper (google)
    google (take a guess)
    qrcode reader
    redlaser - yes
    uk & ROI (mapping)
    rescue me (green flag recovery)
    touch mouse
    iPusher
    viber

    Cydia apps
    VoiceActivator
    TetherMe
    Privacy
    sbSettings (only just added as result of previous reply)
    I also tried the "fix user dir permissions" in sbSettings just to see if that changed anything. It didnt.


    After looking through google images for shots of the settings screen to see if I can find whats missing, i saw one for "Groupon" and downloaded it. This didnt show up in the menu either and it should have one.

    Im lost. I cant see why they arent showing.


    Peter

    Just did a "Reset All Settings" and that didnt help either.
    Last edited by only1pj; 2011-04-26 at 04:16 PM. Reason: Automerged Doublepost
    2011-04-26 04:16 PM
LINK TO POST COPIED TO CLIPBOARD