1. ModMyPi's Avatar
    I purchased an eBay 3GS 16Gb for a bargain because the owner had it stuck in recovery mode and couldn't get it out. Apart from this I had no history of the phone at all.

    On inspection it seems that he or someone else had upgraded the baseband to 06.15.00 to unlock it and this is stock restores wouldn't work at all.

    After much fiddling around I was able to get 4.3.5 installed, but the only way to get it working properly was to use redsn0w which is unfortunately tethered (I hate that!)

    I want to know what is the highest firmware I can apply and have an untethered jailbreak that will also not fail completely due to the 06.15.00 baseband. I have the following SHSH blobs saved:


    I tried going to 4.2.1 however couldn't get it out of the error 1015 recovery cycle.

    Another option I thought of was to try and downgrade the baseband to stock so I can use it as a proper unmodified phone but I am not sure if this is possible yet.

    Any ideas?
    2011-08-23 03:18 PM
  2. akafred's Avatar
    put custom 4.21 or 4.3 on there.. you will have to run jailbreak (redsnow) to get it out of recovery mode
    Last edited by akafred; 2011-08-23 at 03:55 PM.
    2011-08-23 03:52 PM
  3. ModMyPi's Avatar
    which jailbreak for 4.3? I'm pretty sure I tried 4.3 then redsn0w but it didn't work.
    2011-08-23 03:54 PM
  4. akafred's Avatar
    try 4.2.1 get snowbreeze 2.2.1 and make custom firmware. then put phone in dfu mode using snowbreeze or ireb and shift restore the custom firmware. then put in dfu mode again, and run redsnow 9.6.

    dont know if this is the proper way of doing this but its how i had to do it.

    you also have to have tiny unbrella running with the shsh's saved for the firmware your trying to restore.

    if you have the carrier sim dont hactivate the custom firmware in snow breeze, that lead to signal problems on mine. its allways beter to activate using the proper sim then switch to yours after.
    Last edited by akafred; 2011-08-23 at 04:22 PM.
    2011-08-23 04:17 PM
  5. ModMyPi's Avatar
    Thanks for the hint about not checking "activate" in pwnagetool, that is what I must have missed before - got no signal. I've created a custom 4.2.1 with pwnagetool and applied it - it now looks like I have a fully jb phone with 4.2.1 and cydia installed. I didn't use redsn0w at all, is this only a requirement if I used snowbreeze? Pwnagetool seemed to have done everything
    2011-08-23 04:41 PM
  6. Mes's Avatar
    Yes, Pwnagetool and Sn0wbreeze are a full-jailbreak tools.
    Nothing else required except to install Ultrasn0w (via Cydia) for the unlock.
    2011-08-23 05:21 PM
  7. ModMyPi's Avatar
    Thanks for your help everyone. I'm now stable on 4.2.1, however GPS does not work, which is a shame. I wish the previous owner didn't u/g the BB!
    2011-08-23 06:46 PM
  8. akafred's Avatar
    yes you shouldn't need to run redsnow, just on mine with the same symptoms its the only thing that would kick it out of recovery mode with the baseband mismatch..
    2011-08-23 07:19 PM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.