User Tag List

  1. buksida's Avatar
    My 3G iPhone went for a swim, left it drying for a couple of days and now it powers up, shows the Apple logo, then a logo with iTunes and a usb cable.

    When I connect it to iTunes (tried version 8 and 10 on separate computers), it says it needs to check the update server. When I allow it to do this it returns an error stating that it cannot connect to the iPod server (nothing wrong with the internet connection).

    Is there a way to restore this unit? I've downloaded the firmware (3.1.3) again and tried that with Redsn0w but that gives me an error stating that it does not recognise the ipsw file.

    I've tried holding the buttons down for DFU mode, but it just comes back with the connect to itunes logos again.

    Is it toast?
    2011-08-30 07:27 AM
  2. Mes's Avatar
    Likely the water damaged something
    Restoring a 3G to stock 3.1.3 is a simple process with iTunes 10.
    redsn0w should be used 'after' it is restored to 3.1.3.
    2011-08-30 03:57 PM
  3. buksida's Avatar
    Thanks for the reply, any idea why iTunes wont connect to the server then, would the toasted phone cause this?

    Is it bin material?
    2011-08-31 07:39 AM
  4. Mes's Avatar
    That's a different problem. Something within your computer.
    A fresh install may solve it if your internet connection if fine.
    2011-08-31 02:46 PM
  5. buksida's Avatar
    I've tried it on two separate computers with two different versions of iTunes on two different internet connections and both times I get the error "iTunes cannot connect to the iPod server".

    So that eliminates the computer being the problem, it seems to be iTunes ... (or the iPhone)
    2011-08-31 02:50 PM
  6. Mes's Avatar
    Have you turned off all firewalls and anti-virus software?
    That message (I think) is during the authorization stage.
    What about your hosts file, did you delete all gs.apple.com lines?
    2011-08-31 02:53 PM
  7. buksida's Avatar
    OK, will give that a go and report back, thanks for the suggestions.
    2011-08-31 03:52 PM
  8. buksida's Avatar
    Tried it with a Mac this time (didn't work on two PCs) and we got a little more progress, iTunes connected and downloaded the latest iOS for restore.

    It then threw up the following error:

    "The iPhone could not be restored. An unknown error occurred (28)"
    2011-09-01 05:26 AM
  9. Mes's Avatar
    Error 28 is a hardware error. Looks like the water damage was fatal.

    Error 28
    Hardware error. Return your device to Apple if possible. The problem is a bad dock connector on the iPhone. Must change the connector.
    If you have tried almost everything, reset the logic board (leave uncharged for five days or remove battery for half an hour), then pwn and restore. If this doesn't work, the flash memory/hard drive of your device is damaged.

    http://theiphonewiki.com/wiki/index....=ITunes_Errors
    Last edited by Mes; 2011-09-01 at 05:31 AM.
    2011-09-01 05:27 AM
  10. buksida's Avatar
    Ok, thanks for the reply, I'll give it to the kids to play with!
    2011-09-03 03:21 AM
LINK TO POST COPIED TO CLIPBOARD