1. element303's Avatar
    hey guys. i finally made an account in a forum because i am sick of my problem. i jailbroke/unlocked multiple iphones already with problems but never anything like this. i got robbed last week and my iphone was stolen but i was lucky to get an almost brand new 3gs from a friend and customer. it was sadly updated to 4.3.5 which was useless to me because i dont use att.

    so i went home, started the process and downgraded it to 4.3.3 and then the problems began. first off cydia wasnt installed with redsn0w but i downloaded it from jailbr..com. so i unlocked it but didnt get any signal at all. later on i figured out that its better to use the ipad baseband. now this all sounds easy to do, but its not if the phone is stuck in a dfu loop which i think is the case. when i restart (sadly have to happen a lot when restoring and setting up the iphone) is just stays with black screen and itunes find it as recovery mode.

    now here is the real problem. i have made all the research and tried (i think) every single solution which included messing up the ios so i had to restore over and over again because it wouldnt start up at all and the only way (still) to start it, is to hold both buttons for 10-15 seconds and to hope that after 10-30 tries the boot logo shows up. i tried irecovery, fixrec. and so on and on but the big problem i have is that the phone have to be in recovery mode for that to work and i dont have the itunes screen. its just black and appears to be in dfu mode. its currently running but i am afraid to have a restart again and not be able to turn it on again for a while. i actually was able to run irecovery once i got the phone into recovery mode with the itunes logo, but nothing happened with the problem itself.

    can somebody give me a solution that works and hopefully doesnt include another restore? thanks everybody. chris
    2011-09-01 12:56 AM
  2. Mes's Avatar
    Which SHSH blobs do you have? (see Tiny Umbrlla (link below), post #1). SHSH blobs required for any restore, are iDevice + iOS version unique, and can not be shared.
    2011-09-01 01:17 AM
  3. element303's Avatar
    i got a total of 9. from 3.1.2 to 4.3.5 do you need me to list them complete?
    2011-09-01 01:51 AM
  4. Mes's Avatar
    Did you use TU during the previously failed attempts?
    2011-09-01 01:53 AM
  5. element303's Avatar
    no. if i remember right i downloaded it to attempt to exit recovery but the exit button never showed up, only the fix recovery.

    edit: also it said phone not connected.
    2011-09-01 01:59 AM
  6. Mes's Avatar
    That's your problem (or the major one)

    SHSH blobs are required to restore any iOS on a 3GS
    TU is the method to serve to iTunes during the restore.

    Was it unlocked with ultrasn0w before the problems started?
    2011-09-01 02:04 AM
  7. element303's Avatar
    ok i just asked the previous owner. it was jailbroken but not unlocked. i think it ran on att.

    the problems started right after i downgraded to 4.3.3 but i dont recall if it was already when i got because i just turned it off once after i got it. the previous owner just made the original 4.3.5 restore because his problem was that he only had a white screen.
    2011-09-01 02:11 AM
  8. Mes's Avatar
    Ok. We'll try the simple method first - restoring to 4.1

    Delete all lines which contain gs.apple.com from your hosts file.
    Connect the iPhone, wait a min or so, then hold power + home buttons for 6-8 sec
    ... this is a forced power off. Listen for a computer high-low sound
    ... If iTunes opens, leave it open. Ignore iTunes until later
    Run redsnow 0.9.6rc8, select 4.1, select one (1) option, 'just enter pwnd-DFU'
    Shift/select restore 4.1 w/iTunes
    If iTunes 10xx error, use Tiny Umbrella 'exit recovery'
    Done. Restored to stock

    To jailbreak, run redsnow, check install Cydia.

    Use the latest Tiny Umbrella if needed
    Use iTunes 10 or higher.

    When you're done. What is your modem firmware?
    Settings / General / About / Modem firmware
    Last edited by Mes; 2011-09-01 at 02:27 AM.
    2011-09-01 02:24 AM
  9. element303's Avatar
    And this will fix the loop/restart problem? I will try this but not tonight anymore. Thank you very much so far.
    2011-09-01 03:15 AM
  10. Mes's Avatar
    This should work. If it doesn't, we'll do the same except build a custom firmware.

    Note: Many problems occur because the phone's state (off, dfu, or pwnd-dfu) is not set correctly.
    2011-09-01 03:18 AM
  11. element303's Avatar
    there is no way to fix this without restore it again right? all the recovery fixes (such as this Exit iOS 4.3.3 Recovery Mode Loop Using TinyUmbrella (Fix Recovery) | Jaxov) just work with recovery loop or also with whatever my problem is? can you tell me if that sounds like dfu loop?
    2011-09-01 03:26 AM
  12. Mes's Avatar
    No. With all the failed 'over and over' restores, the iPhone contents are gone.
    2011-09-01 03:28 AM
  13. element303's Avatar
    and the problem i have really IS the so called dfu loop? the recovery loop should show the itunes screen or not?
    2011-09-01 03:34 AM
  14. Mes's Avatar
    The current state is unknown ..and.. it doesn't really matter.
    The above procedure should get the device working again. I assume that's what you really want. True?
    2011-09-01 03:38 AM
  15. element303's Avatar
    yes thank you for your time to help! as soon i try it i will let you know how it worked.
    2011-09-01 03:41 AM
  16. Mes's Avatar
    No problem. Good luck
    2011-09-01 03:42 AM
LINK TO POST COPIED TO CLIPBOARD