1. bradbmtl's Avatar
    Hi Everyone. I am new here and relatively new to the Iphone world. On am on my first iphone repair job, and can;`t seem to find anything particular to my exact problem. I have an Iphone 3G, which had a forgotten password. SO I attempted to recover and restore the iphone with itunes while loading a recovery bin, that didnt work, because the result of it was the Iphone telling me to plug into itunes, when I do, I try to restore and get nothing but a 1015 error. I dont know if this Iphone was jailbroken before or what the installed firmwares were... If anyone can help, or point me to a thread that speaks of this issue, I would apprecite it. Thanks alot.
    2011-09-21 07:34 AM
  2. bradbmtl's Avatar
    Im really stumped. I have tried sveral things and still nothing. Since I dont know the history of the phone i dont know what procedure to use to restore it.
    2011-09-21 09:48 AM
  3. N2DEEP3D's Avatar
    You are gonna need to put the phone into DFU mode.

    Basic - plug phone to USB, turn phone completely off, hold down the power and home button for exactly 10 seconds, then release the power button while still holding the home button, after about 6-8 seconds you will here the computer register the phone and itunes will say a phone is in recovery mode, then try and do a restore

    If that does not work, you will either need to use iReb or redsn0w to put your phone into pwned DFU mode, very similar in actions, but you go thru their programs to do it.

    Good Luck.
    2011-09-22 06:26 AM
  4. Mes's Avatar
    What version are you trying to restore ... 4.2.1?

    Use the latest Pwnage or Snowbreeze. It will built a custom firmware and assist entering DFU.
    Then use iTunes shift / select restore.
    No errors are expected.
    2011-09-22 06:54 AM
  5. bradbmtl's Avatar
    Thanks for the help guys. I tried the redsn0w method, all went well with the jailbreaking. But once it was done the iphone again displayed a plug with the Itunes logo. So I plugged it in, and tried to to a restore from itunes without choosing any software and again a 1015 error... Was there something I did wrong? Also Mes, I have been trying to find Pwnage or Snowbreeze for windows operating system, could you point me to them. Thanks
    2011-09-22 08:59 PM
  6. Mes's Avatar
    Did you check the links in my signature pane below?
    2011-09-22 09:16 PM
  7. bradbmtl's Avatar
    Wow! I can believe I didnt see those links. Ill head onto them now. What do you think the trouble is with my iphone? After the Jailbreak it restarts and comes right back on asking to plug in itunes. Do you recommend I use Pwnage or Sn0wbreeze to fix this issue?

    Again, I am not sure what firmware version I should be installing... I used the 3.0.7 restore file with Redsn0w....
    2011-09-22 09:19 PM
  8. Mes's Avatar
    Yes. Pwnage or Snowbreeze are excellent choices.
    2011-09-22 09:22 PM
  9. brijesh33's Avatar
    I had the same problem with my 3gs, i tried everything ireb, snowbreeze..etc but it always stays on restore loop, finally i just went ahead loaded the latest 4.3.5 to bring it back to life.
    2011-09-22 10:14 PM
  10. bradbmtl's Avatar
    Just got everything working with Snowbreeze! Works great. But now I believe the phone is locked because I put my sim card in and get no service. I dony know is iliberty a good programs to use to unlock?

    I dont see Ultrasn0w anywhere here.... I believe this is the program I need to unlock the iphone? I have cersion 4.2.1 with baseband 6.15.00, when I put in SIM card, no service.....
    Last edited by bradbmtl; 2011-09-22 at 10:44 PM.
    2011-09-22 10:18 PM
  11. Mes's Avatar
    Ultrasnow is an app from Cydia. Cydia is on the springboard, page 2 after a new restore.

    To check the baseband version: Settings / General / About / Modem firmware
    2011-09-22 10:47 PM
  12. docmagoo2's Avatar
    Have you tried iReb 4 to kick it out of recovery? Also TU can do this also
    2011-09-24 11:17 AM
  13. confucious's Avatar
    How did you come by a phone which had clearly been unlocked before and not know anything about it or the PIN?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2011-09-24 12:48 PM
  14. Dilla's Avatar
    How do i get raid of error 20...happened when i was trying to downgrade to 4.1.0...What should i do..?
    2011-09-26 08:10 AM
LINK TO POST COPIED TO CLIPBOARD