1. filberto's Avatar
    I was on 5.0.0 iphone 4 jailbroken with redsn0w and semitethered. All was fine then the home button stopped responding and voice control kept popping up (as if I held it down). It's definitely not a hardware problem as I can still boot in DFU mode, so it's software.

    I upgraded to 5.0.1 and jailbroke using redsn0w to fix this, but it is still not responding and voice control keeps coming up. I have to use assistive touch at the moment which is a pain.

    Also semitether says my reboot is protected, yet when I reboot my iphone ends up in a recovery screen. What the hell is going on?! I've tried restoring, using tinyumberella to kick it out of recovery but it goes straight back, I have tried ac1dsn0w and redsn0w to kick it out of recovery but if I boot semitethered it goes to recovery.

    Also are there any suggestions on fixing the home button?

    If not looks like I'm going to have to return this to the apple store...

    2011-12-01 01:36 AM
  2. hcgaloi's Avatar
    I had the same "stuck" home button problem on my iPhone 4. I did a little google search and found a solution by blowing compressed air around the button while pressing/depressing it. This method fixed the problem. I also saw on youtube that people pour a little bit of 99% alcohol on the button and pressing/depressing it. This was my second choice if the first didn't work. Good luck
    2011-12-01 02:41 AM