1. VooDooD's Avatar
    Hi,

    Originally when I paired my phone with my car kit it came up as "Matt's iPhone" which was fine (and derived from the first iTunes sync) but after messing about with an early Youtube unlocker my BT name has somehow gotten changed to localhost.

    Can someone tell me how I go about editing the phone's BT ID? I assume it's in a textfile somewhere but my searching has so far been fruitless...
    2007-10-03 06:35 AM
  2. arthursdomain's Avatar
    sounds like the bt uses your phone name? when you sync to itunes does it still say matt's phone or localhost? if anything you can change it in there.
    2007-10-03 08:54 AM
  3. VooDooD's Avatar
    iTunes still sees it as Matt's iPhone!
    2007-10-03 10:13 AM
  4. VooDooD's Avatar
    OK. Bumping this now as it's getting annoying. Whilst messing about with the 1.1.1 upgrade in the early days I managed to wipe the phone and after a restore to 1.0.2 and IPSF unlock the BT name was correct again. Worked fine until I went through the Independence/iFuntastic jailbreak of 1.1.1 and now it's calling itself localhost again...

    I'm pretty sure that it's something that dropbear does. Anyone have a better idea yet of where the file is on the iPhone that stores the bluetooth name? It's got to be something really simple but the only thing that refers to localhost is /etc/hosts and changing the name there (the :1 entry, not the 127.0.0.1) doesn't make any difference.
    2007-11-10 05:37 AM
  5. sk6's Avatar
    Any update on the issue? My car kit (Parrot CK3100) shows the iPhone with the name "192.168.6.4" which is the IP the iPhone has in my network.

    1.1.2 US iPhone here, jailbroken/unlocked.
    2007-12-10 10:10 AM
  6. VooDooD's Avatar
    I think so... Maybe...

    My issue was with a CK3100 as well. Try clicking on the iPhone in iTunes and do a rename (F2 in Windows) to something else, restart the phone, reconnect and do the rename again to put the old name back.

    I think that's what fixed it for me. If not, it would have been a restore when I was messing around with 1.1.2. I believe that the problems are down to crappy old Dropbear.... If you have to do a clean restore etc just make sure that you don't dropbear at any point.
    2007-12-10 11:03 AM
  7. sk6's Avatar
    Thanks, changing the name in iTunes back and forth solved the problem! :-)

    (I never did anything with dropbear.)
    2007-12-11 07:26 PM
  8. fabiuzz's Avatar
    Could someone help me to change the name of my iphone on my car kit bloutooth?

    My car kit nokia said that the name of may iphone is localhost.

    Thanks
    2008-01-18 10:58 AM
  9. VooDooD's Avatar
    it tells you two posts up!!
    2008-01-19 12:16 AM
  10. ianormok's Avatar
    ey guys, im also encountering the same problem with the BT connection with my car giving the name "localhost".

    I've tried renaming it over and over and no luck with that either.. does anyone have any other suggestions?

    Im running version 1.1.4 on my iphone..
    2008-05-26 02:18 PM
  11. Akuma25's Avatar
    I synced my mine with a Garmin Nuvi 360 and it comes up as local host also. Any idea how I can switch from a bluetooth headset to the garmin bluetooth and change the name?
    2008-06-07 04:13 AM
LINK TO POST COPIED TO CLIPBOARD