1. Nevek's Avatar
    I've been trying to get this phone working and I'm getting no luck. It wasn't mine before (girlfriends) and when I unlocked and jailbroke it for her I must have messed it up. Now I need the phone and I tried to update it to 4.2.1 and this happened. It gets stuck loading on the Apple logo. Then, when I try to restore it I get error 3194. I've tried DFU mode, I've tried looking around in tiny umbrella for help but I get nothing. I believe it has 3.1 on there now, and I would like to run 4.2.1 jailbroken. Any suggestions? I will paypal someone $5 if they can get this going for me so I can stop using my backup Nokia.
    2012-08-10 06:11 AM
  2. Bo Troxell's Avatar
    Error 3194

    Occurs when trying to install an old firmware and Apple's server disallows the installation. The only solution is to have SHSH backup and modify the hosts file to point to Saurik's Cydia Server where they are backed up (or localhost if you have it yourself).
    You can use redsn0w to make a custom stitched firmware if you have the SHSH blobs.
    2012-08-10 06:19 AM
  3. Simon's Avatar
    First confirm that it is a 3G and not a 3GS. A 3G has dark grey writing on back where it says "iPhone", a 3GS has bright silver writing.

    Assuming it is a 3G then you need to fix your hosts file. Tiny umbrella can do this by clicking advanced and deselect the box that says set hosts to cydia on exit. If it is greyed out try finding an older version of tiny umbrella to do it. You can also manually edit this out but that is a bit harder to do.
    2012-08-10 06:25 AM
  4. EVO's Avatar
    since you want to update to 4.2.1 (the latest for 3G), and are receiving the 3194 error, make sure to check your hosts file as mentioned by blkcadi, but you dont need to worry about shsh blobs,

    HOWEVER, in terms of the hosts file, you need to make sure it "doesn't" point to Saurik's server by looking for the hosts entry "74.208.10.249 gs.apple.com", if its there, you have to delete it, then SAVE the hosts file

    then reopen itunes and try restoring to 4.2.1 again, but if you rely on an unlock you must restore to a custom 4.2.1 firmware
    2012-08-10 06:25 AM
LINK TO POST COPIED TO CLIPBOARD