1. ZoobaAruba's Avatar
    I've spent the past two days downloading cydia tweaks on my iphone. Springtomize, SBSettings, Infiniboard and infinidock are a few. I don't usually go on the app store, but my friend recommended a free app to me today and when I went to download it, app store wouldn't recognize it when I hit the "free" button to download the app. I can browse the app store just fine, I just can't download anything. I did a hard reboot, closed all the apps running in the background and tried again, I deleted the last tweak I had downloaded (unlockize) and tried again, still not working. Any ideas/advice?

    Iphone 4s running on OS 5.0.1
    Last edited by ZoobaAruba; 2012-08-16 at 06:21 AM.
    2012-08-16 06:17 AM
  2. DC_Dave's Avatar
    Hi, i could not download App Store apps twice last month. Each time, reinstalling SafariDownload Manager fixed it (presuming you have it!) the other issue I had was with Icon Support, make sure that is on the latest version.
    2012-08-16 03:05 PM
  3. EVO's Avatar
    if you installed those tweaks, then I recommend uninstalling each tweak, each time making a note of which was uninstalled and test the Free download function in the appstore
    2012-08-17 03:30 AM
LINK TO POST COPIED TO CLIPBOARD