1. csc0724's Avatar
    I have an iPhone 4 that magically blacked screen and will not respond to any button commands. with no display i can manage to get it to recovery mode and begin the restore process with iTunes. after the software download i get error message 1601 (unknown error). I've read that this error could be anything from a faulty usb cord to a bad version of iTunes. well i've tried everything i've read so far and i cant seem to get anything to work. this iPhone was jailbroke at the time of the crash. any insight or suggestions would be very much appreciated.
    2012-08-16 06:06 PM
  2. EVO's Avatar
    1600s errors although related to certain issues, but are not specific...

    the 1st thing I would try doing is checking your computer's HOSTS file to verify that the host entry " gs.apple.com" is not there, if it is you must delete it and save the hosts file...

    secondly, were you attempting to restore to a custom firware, or did you let itunes download the firmware?
    2012-08-17 03:06 AM
  3. csc0724's Avatar
    Well to be honest with you, I don't know anything about all the file hosts or how to change it. I have a brand new iMac with mountain lion so I knew the iTunes version and all was good. I tried updating it with iTunes 5.1.1, not anything custom. I also have no idea what program was used to jailbreak it in the first place. Is there a restore program for a jail broke device?
    2012-08-18 12:21 AM
  4. EVO's Avatar
    itunes is the only program used for restoring iOS devices

    here's a video of how to edit the HOSTS file using a MAC:

    make sure "" gs.apple.com" is not in the HOSTS file
    2012-08-20 10:29 AM