1. sincerecorn's Avatar
    I have an ipod 2g, 4.2.1 and it says i cant install features. it says i need an ios>4.0 and i do, its 4.2.1 im using greenp0ison.
    2013-05-06 02:34 AM
LINK TO POST COPIED TO CLIPBOARD