User Tag List

  1. dottorem's Avatar
    Good day to all,

    I am writing this post after having spent no less than ten straight hours in trying to recover an iphone 3GS.
    I was given this broken iphone 3gs which wouldnt even start. So i tried recovering it.
    However when I attempt to do so nothing happens. I have no idea what OS it is on, I have no idea what happened to it nothing.

    I plugged it to itunes where it went straight into a recovery mode, and i attempted to restore and install 6.1.3 -> nothing

    I have downloaded various tools and firmwares and sending it into DFU mode to install -> nothing.

    When i use the fix recovery application, I get a number of errors

    libusb:error darwin transfer status transfer error timed out (from the console)

    then form the phone i get some error at the start about missing

    At the end it tries to download something but it times out. it gives an error, no successful download after 60000ms, giving up. Something related to AppleBCMWLAN

    I literally have tried everything and attempted different versions.
    Can someone give me some advice as to how I can proceed?? I am under the impression that the device is completely wiped out

    I repeat, i have no idea what software it had.

    Thanks in advance to all those who reply. This is a very urgent issue. thanks.
    2013-05-19 09:15 PM
  2. hcgaloi's Avatar
    Your 3gs may have an iPad baseband; if so, it might be the reason you had problem restoring to 6.1.3 using iTunes. Try the below to see if it will help:

    1. Create a custom 6.1.3 firmware with Sn0wbreeze.
    2. Put iPhone in pwned DFU mode
    3. Run iTunes and restore using the custom firmware in step 1.

    If this is successful, you can downgrade the iPad baseband down to 05.13.04. Good luck
    2013-05-20 08:04 PM
  3. dottorem's Avatar
    Pardon my ignorance, but why would an iphone have an ipad baseband? Furthermore, is there completely no way i can find out what ios version it had? nothing?
    Why should a 6.1.3 custom version work? IS there a particular reason i need it custom?

    2013-05-20 08:08 PM
  4. hcgaloi's Avatar
    Back in the days when 3g/3gs were locked to AT&T, people upgraded them to an iPad baseband for a software unlock (Ultrasn0w).

    Regarding why a custom firmware is needed, whenever you do an upgrade/restore with iTunes, it will also check and upgrade baseband to latest version. Since an iPad baseband is incompatible, iTunes would error(s). A custom firmware which preserves baseband (Sn0wbreeze automatically enable this feature) helps to by-pass this problem.
    2013-05-21 01:09 AM
  5. dottorem's Avatar
    By any chance, is there an alternative to sn0wbreeze, which seems to be only for Windows, that I can use on MacOS? There are so many tools with different names that Im getting confused! Thank you for your help so far hcgaloi, greatly appreciated
    2013-05-21 08:39 AM
  6. hcgaloi's Avatar
    Sorry, I'm not a Mac user so I'm not familiar with Mac tools. Off the top of my head, you may want to try Redsn0w to build a custom firmware and do a restore of iOS 5.1.1(the complete process is done by Redsn0w and by-passing iTunes; go to Extra->Restore). Note that after iOS 6.0, Redsn0w has not been upgraded to support newer firmwares.

    Since you don't know the history of the iPhone, let's hope that Cydia has iOS 5.1.1 SHSH blob saved for your phone. If it does, Redsn0w will be able to automatically retrieve it for you. Another note any 6.x.x SHSH blobs from Cydia are invalid, so don't use them. The last working version is 5.1.1. Good luck.
    2013-05-21 07:57 PM
  7. dottorem's Avatar
    Actually I have attempted to restore to 4.1 ... The reason is because redsn0w found blobs of 4.1 for this device. I did not create a custom firmware, but i attempted to restore to the original ipsw... It starts but it stays forever "Preparing iphone software for restore" in itunes. in redsn0w it stays stuck on creating partition map.

    I think im getting somewhere slowly
    2013-05-21 09:13 PM
  8. dottorem's Avatar

    Still no luck at the present moment.

    What I cannot understand is this. Its previous owner damaged considerably its screen whilst he was pushing something with the device in his pocket. In fact the screen (not the display itself) is heavily damaged. When i attempt to restore a firmware, the display itself shows no signs of damage.

    I cannot understand how this physical damage led to the phone not even booting at all. Could it be possible that some internal component was damaged and maybe that is why it is not booting? I was thinking of replacing the battery. Would it make any difference??
    2013-05-26 11:09 AM
  9. baskie's Avatar
    I think you covered what's wrong with it in your first post: it's dead. Bin it and move on.
    2013-05-27 08:47 AM
  10. dottorem's Avatar
    Thank you, your comment was very helpful.
    2013-05-27 09:03 AM
  11. hcgaloi's Avatar
    Did you do a 4.1 restore under pwned DFU mode? If you have access to a PC, let's try this:

    1. Download iREB and Sn0wbreeze from
    2. Download official iPSW 4.1 (you can search
    3. Run Sn0wbreeze and build a signed 4.1 custom firmware using 4.1 blob retrieved by Redsn0w in post #7
    4. Run iREB, click on pwned DFU and follow instructions on screen
    5. Run iTunes and Shift+Restore and select the custom firmware in step 3

    Good luck
    2013-05-28 09:41 PM
  12. misstechy's Avatar
    I had my iPhone 3GS updated last night to the latest iOS 6.1.3 and I was able to hactivate it. The only problem I encountered was it didn't have any network. I tried to fix it again but the problem is always putting the phone in DFU mode because my home button is not functioning anymore. I found a youtube vid on how to put the device in DFU mode and it worked last night and worked today as well.

    I opened redsn0w and it recognized that the phone is in DFU mode, however, it gave an error that I wasn't sure what it was. Found out that my phone has a total black screen and won't turn on anymore. I've search youtube vids for solution but all of them is saying to hold the power and home button again etc.... I CAN NOT DO because HOME BUTTON is NO LONGER FUNCTIONING!

    I tried to connect to iTunes but it wont detect anymore so I tried to connect to a power source this time hoping it'll light up. Up to this time I'm typing this message, it's still on power source but still on black screen.

    Please help!
    2013-06-01 04:28 PM