1. antsu's Avatar
    I just went to see if any updates on Cydia and all my repos are gone. Was gonna check if Saurik got mobilesubstrate updated for my iPad 3 and 5 iOS 7.0.4.I cant even re add any of the default repos on iPhone. All ok on iPads.

    I get this error as goto Cydia: Type 'rsh' is not known on line 1 in source list /etc/apt/sources.list.d/saurik.list

    Same error if try to add any repo. Everything does work ok on the phone but Cydia useless if no repos.

    iPhone 4
    iOS 6.1.2
    Cydia 1.1.9
    Normal evasion jb

    I havent updated anything or installed in ages. Worked ok yesterday. Now I am clueless what to do? Reinstall Cydia? Try to fix that file?

    Any advice appriciated

    -antsu
    2013-12-26 09:59 PM
  2. Primology's Avatar
    Hey Antsu

    Q: Do you see Sources ?
    Q: Can You Refresh ?

    Try Changes > Refresh and let it update
    Try Manage > Sources > Edit > Delete One-Two Sources and restart Cydia (Delete zodttd repo if unneeded)

    Explain Better if i got something wrong .. i had a problem when i overfilled Cydia with Sources
    2013-12-26 11:27 PM
  3. antsu's Avatar
    Hi
    No cant see any sources. So cant see any apps either. Clicking 'section' gives an empy 'all packages' link.

    On main page can see link for 'more sources', open ok, can see the list and default ones, but cant add any due to mentioned error in red on screen. Same happens if I try to hand add a source by address. Error.

    I cant delete any source as there are none. Cant refresh in 'changes' as no sources. And I really wouldnt want to upgrade to ios 7 as dont like it.

    Maybe that saurik.list is somehow corrupted? Maybe need to get a new one from somewhere or what it does and should contain?
    Last edited by antsu; 2013-12-27 at 09:55 AM. Reason: Typo
    2013-12-27 09:54 AM
  4. Primology's Avatar
    let me do some research and i will try to solve ur problem
    2013-12-27 12:31 PM
  5. skiptowncat's Avatar
    I had Cydia go completely empty once, here's what I did.
    Navigate to /var/lib/apt/lists
    Delete everything EXCEPT the partial folder, reboot. Should be good to go.
    2013-12-27 01:04 PM
  6. Primology's Avatar
    use iFile or iFunBox , navigate to /etc/apt/sources.list.d/saurik.list (Don't edit if u don't have to) , check the file see if it has rsh in line 1 or something.

    Or navigate to /etc/apt/sources.list.d/cydia.list and ,edit and delete an unneeded repo
    2013-12-27 02:34 PM
  7. antsu's Avatar
    This is what have:

    antsu:/ root# uname -a
    Darwin antsu 13.0.0 Darwin Kernel Version 13.0.0: Sun Dec 16 19:58:12 PST 2012; rootnu-2107.7.55~11/RELEASE_ARM_S5L8930X iPhone3,1 arm N90AP Darwin


    antsu:~ root# nano /etc/apt/sources.list.d/cydia.list

    Code:
    deb http://apt.saurik.com/ ios/793.00 main
    deb http://cydia.zodttd.com/repo/cydia/ stable main
    deb http://apt.thebigboss.org/repofiles/cydia/ stable main
    deb http://apt.modmyi.com/ stable main
    antsu:~ root# nano /etc/apt/sources.list.d/saurik.list

    Code:
    rsh^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@$
    That saurik.list doesnt seem right. cydia.list seems to be ok.

    EDIT: Added dir listing of /var/lib/apt/lists

    Code:
    antsu:/var/lib/apt/lists root# ls -la
    total 46160
    drwxr-xr-x 3 root wheel     1088 Dec 25 15:04 ./
    drwxr-xr-x 4 root wheel      170 Dec 25 15:07 ../
    -rw-r--r-- 1 root wheel     1341 Dec 24 21:01 apt.modmyi.com_dists_stable_Release
    -rw-r--r-- 1 root wheel      198 Dec 25 15:04 apt.modmyi.com_dists_stable_Release.gpg
    -rw-r--r-- 1 root wheel 16157289 Jun 14  2013 apt.modmyi.com_dists_stable_main_binary-iphoneos-arm_Packages
    -rw-r--r-- 1 root wheel    53337 Dec 24 21:01 apt.modmyi.com_dists_stable_main_binary-iphoneos-arm_Packages.IndexDiff
    -rw-r--r-- 1 root wheel      627 Dec 24 15:08 apt.saurik.com_dists_ios_793.00_Release
    -rw-r--r-- 1 root wheel      189 Dec 25 14:59 apt.saurik.com_dists_ios_793.00_Release.gpg
    -rw-r--r-- 1 root wheel   138993 Dec 25 14:59 apt.saurik.com_dists_ios_793.00_main_binary-iphoneos-arm_Packages
    -rw-r--r-- 1 root wheel      471 Dec 25 04:17 apt.thebigboss.org_repofiles_cydia_dists_stable_Release
    -rw-r--r-- 1 root wheel      198 Dec 25 14:59 apt.thebigboss.org_repofiles_cydia_dists_stable_Release.gpg
    -rw-r--r-- 1 root wheel  9254154 Jun 16  2013 apt.thebigboss.org_repofiles_cydia_dists_stable_main_binary-iphoneos-arm_Packages
    -rw-r--r-- 1 root wheel    53036 Dec 25 14:58 apt.thebigboss.org_repofiles_cydia_dists_stable_main_binary-iphoneos-arm_Packages.IndexDiff
    -rw-r--r-- 1 root wheel     1670 Dec 25 10:00 cydia.zodttd.com_repo_cydia_dists_stable_Release
    -rw-r--r-- 1 root wheel      189 Dec 25 10:00 cydia.zodttd.com_repo_cydia_dists_stable_Release.gpg
    -rw-r--r-- 1 root wheel 10062879 Jan  1  1970 cydia.zodttd.com_repo_cydia_dists_stable_main_binary-iphoneos-arm_Packages
    -rw-r--r-- 1 root wheel    53073 Dec 25 10:00 cydia.zodttd.com_repo_cydia_dists_stable_main_binary-iphoneos-arm_Packages.IndexDiff
    -rw-r----- 1 root wheel        0 Jan  1  1970 lock
    drwxr-xr-x 2 root wheel       68 Dec 25 15:04 partial/
    -rw-r--r-- 1 root wheel      683 Feb  6  2013 repo666.ultrasn0w.com_._Packages
    -rw-r--r-- 1 root wheel      283 Feb  6  2013 repo666.ultrasn0w.com_._Release
    Did this: antsu:/var/lib/apt/lists root# rm repo666.ultrasn0w.com_._*

    Rebooted twice. No change. Looks like its that saurik.list giving the probs. Dunno if made a change, but after logged in with my ipad 3 and 5 after installing 7.0.4 and jb and going into cydia manage accout iphone started to have issues. Well, only that lost all sources.
    Last edited by antsu; 2013-12-28 at 12:09 PM.
    2013-12-28 11:52 AM
  8. skiptowncat's Avatar
    I had Cydia go completely empty once, here's what I did.
    Navigate to /var/lib/apt/lists
    Delete everything EXCEPT the partial folder, reboot. Should be good to go.
    Did you try this?
    2013-12-28 07:43 PM
  9. antsu's Avatar
    Did that too...except renamed folder and copied that folder back. Just dont see the point how deleting all sources would bring them back?
    2013-12-28 08:36 PM
  10. Cmds187's Avatar
    default sources keep and the rest delete if u install modmyi repo delet it this happen to me
    2013-12-28 09:16 PM
  11. Primology's Avatar
    Simple.. the problem is this "/etc/apt/sources.list.d/saurik.list" !

    https://www.mediafire.com/?a0upxi4q31m0c7e

    Download and use mine Here is what it looks like

    Cydia lost all repos suddenly? How to readd?-img_0212.png

    And a little advice , let the Delete button be ur last resort (don't rush)
    2013-12-29 01:31 PM
  12. antsu's Avatar
    Wtf?

    # DO NOT EDIT | This is the story of a time long ago, A time of myth and legend, when the Earth was still young.
    # The ancient gods were petty and cruel, and they plagued mankind with suffering and beseiged them with terrors.
    2013-12-29 11:53 PM
  13. Primology's Avatar
    My Cydia Works Perfectly , it's a Evasi0n Jailbreak on iPhone 4 6.1.2

    Any Low Brained Human would see that Cydia already told you it has a problem in: Type 'rsh' is not known on line 1 in source list /etc/apt/sources.list.d/saurik.list

    From my perspective:
    Error Location: /etc/apt/sources.list.d/saurik.list
    Error File Line: 1
    rsh clearly not declared!

    So it's your choice not mine, i am not here to beg you to try the file or anything even CLOSE to that ..!

    Other than that have fun using iOS7 or if you have working ShSh for iOS6 then Restore & Jailbreak
    p.s. Make a Backup of sources.list.d folder just in case.
    2013-12-30 02:04 PM
  14. ian2close's Avatar
    thanks alot primology this works for me I've just downloaded his saurik.list and change mine using Ifunbox via Windows 7 PC and works fine. I've got same problem as mention above. By the way I'm using iphone 3gs 6.1.2
    2014-01-02 05:57 AM
  15. Primology's Avatar
    You are very welcome
    2014-01-02 05:53 PM
  16. antsu's Avatar
    Sorry been offline. That actually works. My 1st thought was that wtf is that. Txt didnt seem to relate to Cydia in anyway. Just edited file and all ok now. I just wonder how the original got lost.

    tnx
    2014-01-09 12:19 PM
  17. Primology's Avatar
    That i don't know , and when i first say the saurik.list my thoughts were the same And you are welcome :3
    2014-01-09 03:57 PM
  18. MarkModMy's Avatar
    Hi Primology, Appreciate what you've instructed so far, and admittedly a semi-noob here armed with barely enough info to be dangerous! I have same "rsh not known line 1" issue, tried all refeshes, restarts, etc.
    So, I d/l'ed iFunBox, attached iPhone 3GS, am at the folder nav, I see Cydia there...
    now I need a step by step on exactly where/what to change, if you would be so kind? Mahalo!
    2014-01-25 10:22 PM
  19. Primology's Avatar
    go to /etc/apt/sources.list.d and replace the saurik.list file You are welcome
    2014-01-26 07:51 PM
  20. MarkModMy's Avatar
    Took me a bit to find the right path, was used iFunBox and after clicking my device (bottom left of menu), I had been looking in wrong folders instead of:
    Raw File System, THEN etc, THEN apt, THEN sources... got it now, worked great, all "stuff" back where it used to be. Many sincere thanks!
    2014-01-26 11:12 PM
26 12
LINK TO POST COPIED TO CLIPBOARD