1. ame235's Avatar
    hello,

    i have a problem with my cydia.

    this is what i get:
    iPhone:~ root# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    The following packages will be upgraded:
    sudo
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/112kB of archives.
    After unpacking 4096B disk space will be freed.
    Do you want to continue [Y/n]? Y
    dpkg: parse error, in file `/var/lib/dpkg/status' near line 23 package `sudo':
    field name `/etc/sudoers' must be followed by colon
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    iPhone:~ root#
    i get this for all other installs also.

    what is the problem, and how can i solve it?
    I already tried:
    - apt-get clean
    - various reboots
    - visudo for editing that /etc/sudoers file

    nothing worked.

    PLZ, anyone, help !

    Ok, solved alone.

    For some reason there is a status-old file in the /var/lib/dpkg directory.
    so i replaced old one with that one.

    ls /var/lib/dpkg
    cp status status_bak
    rm status
    cp status-old status
    ---
    if everithing goes ok like it went for me then:
    rm status_bak
    dunno why i got in this situation,
    but if i did, some others will.

    Hope this will solve somebody's problem.
    Last edited by ame235; 2008-04-17 at 03:47 PM. Reason: Automerged Doublepost
    2008-04-17 03:45 PM
LINK TO POST COPIED TO CLIPBOARD