1. smeeshum's Avatar
    Used Cydia to install a new slider, didnt like it, removed it using Cydia, now I HAVE NO SLIDER!!!! I dont want to do a restore cos it takes hours!!!

    I tried installing a new slider from Cydia and got an Error 1 Message telling me there was a problem with a pre-installed script.

    at least it still works, very hard to do though without the slider to actually move with my finger. Very tempremental.
    Please Help

    exact error message is
    subprocess pre-installation script
    returned error exit status 1
    Last edited by smeeshum; 2008-07-21 at 04:11 PM. Reason: Automerged Doublepost
    2008-07-21 04:11 PM
  2. djakarta's Avatar
    i also lost my battery icon when i tried to uninstall something that i didn't like. iT keep showing the error msg when i tried to install the new battery
    2008-07-21 05:40 PM
  3. danmatthews84's Avatar
    I pwned my iPhone yesterday from 2.0. Everything seems ok except a few problems.

    I installed the cannabis slider, then when I tried to install a different slider I got an error message. Now there is no slider present and I get error message when trying to install new ones from cydia.

    The official app store applications crash everytime I open them

    I installed NES from cydia. It works fine and is a great app but I cant save progress.

    Any help on these issues would be much appreciated.
    2008-07-21 06:18 PM
  4. smeeshum's Avatar
    Regards your appstore apps, just uninstall a free one, re-install it and it should work. If not you'll have to take them all off and put them back on 1 by 1 bud.

    Any resolve on my issue yet? I still have no slider. Im going to planet-iphones to try and find the creator.

    Smee
    2008-07-21 06:27 PM
  5. stlcaddie's Avatar
    I have the same problem....lost my battery icon and my notes layout cause I didn't like what I downloaded so I tried another. Now I get the same error messages ya do.
    2008-07-21 06:51 PM
  6. smeeshum's Avatar
    any ideas on this now there's clearly more people online this evening??
    Cheers
    Smee
    2008-07-21 10:01 PM
  7. questioncom's Avatar
    it happened to me too. i refuse to use any of those batts or sliders till summer board or installer is released. all i have is the t zones hack and poof
    2008-07-22 04:17 AM
  8. Freakin's Avatar
    Happened to me as well. I broke my phone (had to restore) just before figuring out how to fix it.

    See here

    And find the relevant slider names/locations.

    You can google image results for most of them and SCP them back to the proper location.

    *EDIT* The only one I don't see a listing for is the green "answer phone" slider. The gray & red are both there and available by google image (search for image name)
    Last edited by Freakin; 2008-07-22 at 05:04 AM.
    2008-07-22 05:00 AM
  9. mezbomber's Avatar
    Hello...I just joined these forums because I just Pwned my 3g, and would like to stay in the know about such things. This disappearing slider thing is the first problem i've encountered.

    @Freakin
    can you help with command for "SCP'ing" my slider back into place within the terminal?
    this is what I tried:

    "scp bottombarknobgray.png [email protected]:/System/Library/
    PrivateFrameworks/TelephonyUI.framework/"

    I'm not too familiar with Terminal yet, and just took a guess based on the method I just learned for uploading NES roms into my iPhone.

    also, after finding the original slider image and downloading it, is there any specific directory that it needs to be in before I "scp" it back into my iPhone?

    thanks for any help you can offer.
    2008-08-01 06:19 PM
  10. Freakin's Avatar
    Hello...I just joined these forums because I just Pwned my 3g, and would like to stay in the know about such things. This disappearing slider thing is the first problem i've encountered.

    @Freakin
    can you help with command for "SCP'ing" my slider back into place within the terminal?
    this is what I tried:

    "scp bottombarknobgray.png [email protected]:/System/Library/
    PrivateFrameworks/TelephonyUI.framework/"

    I'm not too familiar with Terminal yet, and just took a guess based on the method I just learned for uploading NES roms into my iPhone.

    also, after finding the original slider image and downloading it, is there any specific directory that it needs to be in before I "scp" it back into my iPhone?

    thanks for any help you can offer.

    Hey,

    So here is what you have to do.

    Download Winscp (winscp.net)

    You are going to connect to your iphone over SSH. If you do not have SSH installed or configured on your phone yet, check out the SSH Access section on the main page of Cydia on your iphone.

    Once you can connect w/ WinSCP, you can browse your iphone's directories remotely across Wifi. If your iphone goes to lock screen, your SCP/SSH session will disconnect within 30 seconds, so keep your phone active.

    Browse to the directory (using WinSCP) where the sliders should be located, which I think is /System/Library/PrivateFrameworks/TelephonyUI.framework/

    Drag the files from your computer into the right-side of WinSCP (where you are looking at that TelephoneyUI.framework directory) to upload the files to your phone.

    Respring and you should be good to go.

    Alternatively if the slider images are on the web (http://iphone.tgbus.com/zt/iphonezt/...barknobred.png for example) then you can probably use terminal on your phone, navigate to that directory with CD, then do a wget http://iphone.tgbus.com/zt/iphonezt/...barknobred.png to download the files to that directory. If you don't have wget installed, either install it with Cydia (it's a command line tool) or see if you have curl installed (another command line tool) with the command curl http://iphone.tgbus.com/zt/iphonezt/...barknobred.png

    Respring after replacing these files.
    2008-08-05 03:09 AM
  11. 808mp5's Avatar
    too bad you didin't see my post before you lost your image...
    http://www.modmyi.com/forums/cydia-s...s-warning.html

    haven't tried any of the above methods... though customize might work... im sure if you can find the default locations of missing images they can be replaced... i just restored and repwnd
    2008-08-05 03:16 AM
LINK TO POST COPIED TO CLIPBOARD