User Tag List

  1. BananaBonanza's Avatar
    Okay, recently installed 2.0 and Cydia. However I can't modify the OpenSSH settings as I could with Installer on 1.1.4...

    I'm trying to change the SSH port and disable password login, but changes to /etc/ssh/sshd_config seem to be ignored, even after reboots. Where do I properly configure it?
    2008-07-23 09:53 AM
  2. lehighkid's Avatar
    I have successfully modified my OpenSSH installation from Cydia on 2.0 to use key verification only and add a banner by modifying the /etc/ssh/sshd_config file. Changes were instantaneous. I also found that the sshd_config file differed from that of my leopard and ubuntu setups and applying the same settings would prevent access.

    My suggestion would be to keep a connection open while you modify the sshd_config file and test with another connection.

    HTH
    2008-07-23 12:06 PM
  3. BananaBonanza's Avatar
    It simply won't work for me.
    I get "DB_CREATE must be specified to create databases". Are the preferences actually stored in a sqlite database? I tried reinstalling that, but it didn't help.

    Okay, that error message apparently came from vi. Editing with nano doesn't result in that error.

    Also I found out that /etc/sbin/sshd -i reads the file correctly. It's just the service that ignores it. Even adding noise to the file doesn't change anything. Weird.
    Last edited by BananaBonanza; 2008-07-23 at 09:36 PM. Reason: Automerged Doublepost
    2008-07-23 09:36 PM
  4. RichH's Avatar
    It simply won't work for me.
    I get "DB_CREATE must be specified to create databases". Are the preferences actually stored in a sqlite database? I tried reinstalling that, but it didn't help.

    Okay, that error message apparently came from vi. Editing with nano doesn't result in that error.

    Also I found out that /etc/sbin/sshd -i reads the file correctly. It's just the service that ignores it. Even adding noise to the file doesn't change anything. Weird.
    AFAICT, nvi (which is what the vi for Cydia seems to be really)
    uses Berkeley DB for its temp storage. Some Linux builds
    also got this message when they switched from Berkeley DB
    4.5 to 4.6 (google for the message). Not sure whether they
    got around to fixing it either...
    2008-10-27 04:30 PM
LINK TO POST COPIED TO CLIPBOARD