1. aprilraine's Avatar
    I have a similar problem. My ipod touch is stuck at the connector and itunes logo. When I connect my ipod to my usb belkin connector my computer or itunes doesn't detect it, so I can't restore back to factory settings and I tried holding down the sleep button and the home for 10 secs to go into dfu mode and it just shuts off. The ipod is an 8gb jailbroken 1.1.2. I tried connecting to different usb ports, upgraded itunes, the only thing I think of is belkin connector I just bought a day ago. I haven't used until I was faced with this problem. Does anybody have any suggestions?
    Okay so. I have the same thing whats wrong with it..It wont detect it on itunes..so im not sure what do. did you end up fixing it? How did you do it? Please help. Or anyone else who fixed it, or can tell me how to! I tried like...restoring it and stuff, like what other people said on youtube and google and on here. But its still not working...It doesnt even say on itunes that it found something in recovery mode? :S

    My ipod touch 8gb 2nd generation is stuck on the connect to itunes store. itunes doesnt detect that its plugged in. i tried to do what youtube and google people say...but it still doesnt work, and i tried plugging it into another computer and a ipod player. Please help. how do i get it working again..it started when i had to update it to put apps on my ipod touch, it said there was like a unknown problem with it
    Last edited by aprilraine; 2010-10-23 at 07:55 PM. Reason: Automerged Doublepost
    2010-10-23 07:55 PM
21 12