1. fender0327's Avatar
    I just bought a touch on Monday with 1.1.3 firmware. When I tried downgrading it to 1.1.1, I got an error 1 code. I found some articles that stated in order to downgrade 1.1.3 to 1.1.1, I'd have to be running iTunes 7.5. I cannot find this download anywhere. Every site redirects me to Apple, which prompts me to download 7.6. Does anyone have a work around? Also, is there an archive for the firmware releases? I found a direct link to 1.1.1, but can't find anything else.
    2008-01-24 11:45 PM
  2. nate513's Avatar
    Here is the link to all the firmware versions for the ipod touch http://wiki.iphonegameover.com/Firmware_download. Here is the link for old versions of itunes http://www.oldapps.com/itunes.htm. Hope this helps!!!
    2008-01-25 03:56 AM
LINK TO POST COPIED TO CLIPBOARD