1. Websteria's Avatar
    This appears to be an oversight on this release. I'm sure Saurik is working on a fix, but for now copying the info.plist from your Winterboard.app file into the proper location and setting the permission will fix it.

    Thanks!
    Jeff
    2008-08-11 08:33 PM
  2. Talynrider's Avatar
    In the first post Saurik mentioned some new .plist mods but didn't say what they were. I checked the new "Themes and Theme Elements" but don't see anything new. Anyone know what these are?
    2008-08-11 08:42 PM
  3. gastonm's Avatar
    This appears to be an oversight on this release. I'm sure Saurik is working on a fix, but for now copying the info.plist from your Winterboard.app file into the proper location and setting the permission will fix it.

    Thanks!
    Jeff
    So what you're saying is mine is current and once i copy the plist it will be fine? But what about the version number difference? and I don't see any of the new features in mine. I think it's still the old one.
    JESUS CHRIST SAVES

    Unlocked Tmobile
    2008-08-11 08:43 PM
  4. haros21's Avatar
    I think your on to something this files is not in my folder. Can someone host this so i can move it there and see? Or tell me where it is in package?



    SO that was the problem. Good Idea Paez. I took the Plist (Info.plist) file out of the Winterboard application folder moved it to my desktop changed the name to what you provided (com.saurik.WinterBoard.plist) and moved it to the preferences folder. Made sure it was set to 644 and now it works. I love to solve a mystery.... Yay.
    Do what aziphrale says. Worked perfectly. Thanks!
    2008-08-11 09:00 PM
  5. ch0b1ts's Avatar
    People mention that the settings are unselected when they respring.
    Try checking the permissions of this file....
    /private/var/mobile/Library/Preferences/com.saurik.WinterBoard.plist
    ...that where winterboard saves its settings.
    Mines 0644 and my winterboard works.
    This file doesn't exist on mine. I'm guessing that might be a problem.
    2008-08-11 09:05 PM
  6. PAEz's Avatar
    By the way just copying that file over isnt the best idea, itll prolly work but might cause problems later as it contains keys that shouldnt be there.
    You want the contents of the file to be....
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    </dict>
    </plist>
    2008-08-11 09:17 PM
  7. crimsontwo's Avatar
    Still doesn't answe the question why some people have this and others don't Thanks for the file though.
    2008-08-11 09:57 PM
  8. lankkari's Avatar
    for all of those who doesn't have the file:

    it exists in /applications/winterboard and it's name is info.plist

    you then have to rename it as you have been told
    2008-08-11 10:02 PM
  9. PAEz's Avatar
    DONT use that file unless you change its contents.
    Just create a file on your desktop called...
    com.saurik.WinterBoard.plist
    ...open it and paste this into it....
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    </dict>
    </plist>
    ....and place that file in this directory....
    /var/mobile/Library/Preferences/
    ...if you use the info.plist it has information in it that doesnt get removed and may cause problems later
    2008-08-11 10:07 PM
  10. bayloc's Avatar
    DONT use that file unless you change its contents.
    Just create a file on your desktop called...
    com.saurik.WinterBoard.plist
    ...open it and paste this into it....
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    </dict>
    </plist>
    ....and place that file in this directory....
    /var/mobile/Library/Preferences/
    ...if you use the info.plist it has information in it that doesnt get removed and may cause problems later

    do we add that to whats in there already or just have that in there. i edited with notepad and just replaced what was in it with that.

    2008-08-11 11:01 PM
  11. PAEz's Avatar
    You did the right thing, you only want that in your file.
    It might be nothing, but its best to be on the safe side and do it right.
    2008-08-11 11:10 PM
  12. Brownsound's Avatar
    Not working here either on 3G iPhone with 2.0.1. I even did a fresh restore and still nothing.

    I noticed that no matter what I check / reorder in the list, it doesn't stay that way after I respring. It goes back to the original ordering and with nothing checked. Permissions problem maybe?
    Exact same situation here.
    2008-08-11 11:21 PM
  13. bayloc's Avatar
    Exact same situation here.
    fix has been discovered in this thread. please read.

    2008-08-11 11:24 PM
  14. johnny69blaze's Avatar
    Good to know and it works! Thank you o' wise one!

    DONT use that file unless you change its contents.
    Just create a file on your desktop called...
    com.saurik.WinterBoard.plist
    ...open it and paste this into it....
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    </dict>
    </plist>
    ....and place that file in this directory....
    /var/mobile/Library/Preferences/
    ...if you use the info.plist it has information in it that doesnt get removed and may cause problems later
    2008-08-11 11:24 PM
  15. gastonm's Avatar
    You did the right thing, you only want that in your file.
    It might be nothing, but its best to be on the safe side and do it right.
    I just now saw the update and will see if I see the issues others are having.

    ok I just updated it and everything seems to work fine... Except for the black navigation bar option. (what exactly is that? what should it do?)
    Last edited by gastonm; 2008-08-11 at 11:47 PM. Reason: Automerged Doublepost
    JESUS CHRIST SAVES

    Unlocked Tmobile
    2008-08-11 11:47 PM
  16. Funkquito's Avatar
    Great now it works! Thanks everyone for the help
    2008-08-12 12:24 AM
  17. Talynrider's Avatar
    The black bar element will change the top bar right below the status bar (in phone, text ect) to black instead of the blue grey.
    2008-08-12 01:05 AM
  18. stelmax's Avatar
    I got everything to work, it's just the black navigation bars option that doesn't change anything for me, as I understand the same problem as others that posted before.
    My question is, is there anyone that has the black bars working?
    2008-08-12 01:08 AM
  19. spam_artist's Avatar
    @stelmax: read the post right above you...it works...

    btw, i saw that there's a new update on winterboard just now...
    maybe he fixed it, now it's ver0.9.2520-2
    2008-08-12 01:13 AM
  20. dakomo's Avatar
    I think it works better this time, thanks to app dev for the new update.

    Still.. Black Navigation Bars feature cannot be disabled. And, the new features won't work with Themes.
    iPhone 3GS 32gb | iOS Jailbroked | Winterboard Custom Theme| Ultrasn0w Unlocked
    AMD X2 2.6GHz CPU (Overclocked @ 3.2Ghz) | Asus M2N-SLI Mobo | G.Skill DDR2800 2GB Mem
    Xbox360 Elite | XCM CPU/GPU Fan | Talismoon Fan | Xecuter NAND/JTAG | iXtreme LT Firmware
    Toyota 2JZ-GE | Turboeast Stage 1 Turbo Kit | Haltech F10x Fuel EMS | AEM Boost & A/F Gauges
    2008-08-12 01:57 AM
72 1234
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.