User Tag List

  1. Comedy's Avatar
    Yesterday Cydia stopped installing any apps.. It would go to the install screen, go blank and then just show the 'Return to Cydia' button and nothing would be installed.

    I tried via the command line to install sometheing through apt-get (just to see what the errors are) and I'm getting this:

    dpkg: failed in buffer_read(fd): copy info file '/var/lib/dpkg/available': Device not configured


    Has anyone seen this problem before?.. I know it's not Cydia specific but if anyone has had it I'd appreciate some pointers on how I can fix or should I head off to a debian support forum.


    Thanks

    Incase anyone's wondering this sorted it:

    dpkg --clear-avail && apt-get update

    Unlikely anyone's that bothered though considering how rare the problem is.
    Last edited by Comedy; 2009-02-04 at 07:57 PM. Reason: Automerged Doublepost
    2009-02-04 07:57 PM
  2. llescaflownell's Avatar
    i have the same problem, but i don't know how you fixed it, can you do a step by step solution? Thanks a lot.
    2009-02-05 09:58 PM
  3. Comedy's Avatar
    firstly you'll need to have mobileterminal installed or some way to ssh into your phone.

    In the terminal type the following:

    su
    -password is alpine

    dpkg --clear-avail

    apt-get update

    Then go back into Cydia and all should be good.


    If you don't have MobileTerminal but you do have Installer I think you can still install it that way. If you get stuck or it doesn't work let me know what goes wrong and I'll try to think up something else.
    Last edited by Comedy; 2009-02-06 at 03:57 PM.
    2009-02-06 03:55 PM
  4. llescaflownell's Avatar
    Thank you so much for the tip, however, I did what you said, and at the end, it states:

    "Some index files failed to download, the have been ignored, or old ones used instead."

    Is this okay?
    2009-02-06 08:58 PM
  5. Comedy's Avatar
    Yeah, I'm pretty sure I got the same message. Try Cydia again
    2009-02-07 07:57 PM
LINK TO POST COPIED TO CLIPBOARD