1. mike8333's Avatar
    Hi all,

    I am trying to change the springboard icon for "The Straits Times" app (from appstore) in Winterboard.

    I normally just need to place an icon(xxxx.png) into the icons folder in the specific theme.
    But for this app it doesn't work and I am quite sure it is not the icon name that is wrong.

    SSH into the app folder(SPHNewsgator.app), weirdly I found that it contain 4 files tat might "create" the default icon.

    st_icon.png (square pic without gloss, rounding and shadow)
    thumbnailgloss.png
    thumbnailframe.png
    thumbnailshadow.png

    Things tried tat don't work:
    .I tried placing a SPHNewsgator.png in Winterboard
    .Change names combo(upper case, lower case too)
    .Tried replacing st_icon.png directly end up with my icon in a icon
    .Tried blanking thumbnailgloss.png, thumbnailframe.png, thumbnailshadow.png (still get icon in icon)
    .There's an icon.png in the folder but it isn't the same 1 showing up in springboard, tried replacing it, also don't work.

    Can any kind (expert) soul show me how to get around this problem? Thanks in advance.

    Mike --
    2009-05-13 01:33 PM
  2. PotatoHead's Avatar
    All you have to do is name the icon "Straits Times.png" and put it in your icons folder. Then just respring or go into winterboard and unselect and reselect your theme.

    When saving the icon make sure it appears exactly as it does on the springboard. I should be saved exactly as I typed it above. Make sure there is a space in between the two words, with no underscore or dash. Also it is case sensitive the "S" and "T" must be capital.

    Try it and see if it works.

    All you have to do is name the icon "Straits Times.png" and put it in your icons folder. Then just respring or go into winterboard and unselect and reselect your theme.

    When saving the icon make sure it appears exactly as it does on the springboard. I should be saved exactly as I typed it above. Make sure there is a space in between the two words, with no underscore or dash. Also it is case sensitive the "S" and "T" must be capital.

    Try it and see if it works.
    Last edited by PotatoHead; 2009-05-16 at 09:42 AM. Reason: Automerged Doublepost
    2009-05-16 09:42 AM
  3. mike8333's Avatar
    Hey thanks...it works!

    I swore I tried tat earlier but it didn't work(maybe it is either spelling or caps error)
    2009-05-21 01:17 PM
  4. PotatoHead's Avatar
    It happens to the best of us. I've had many problems like yours. Sometimes its just a brain fart. You know what should be there and when you look at it that's what you see.

    Well if you have any other questions let me know. I'm happy to help!
    2009-05-22 08:30 AM
LINK TO POST COPIED TO CLIPBOARD