1. electroblaze's Avatar
    I just JBed my Touch running OS 3.0 with redsn0w...the Cydia part works fine...but the applications just don't show up on the home screen..help plz..
    2009-06-22 08:27 AM
  2. xSceneMidgetx's Avatar
    Reboot .. still nothing?
    2009-06-22 10:00 PM
  3. swimin304's Avatar
    i have the very same problem.
    2009-06-23 07:25 AM
  4. crakky's Avatar
    I have the same issue too. For me it has an error with the dpkg file. It says I have to update the Debian Packager I get the error Couldn't configure pre-depend dpkg for grep, probably a dependency cycle. Anyone know how to fix this? Is this the same error you guys are getting too?
    2009-06-23 08:37 AM
  5. swimin304's Avatar
    i had to clear the memory, restore defaults, restore defaults, re-JB then restore, download cydia packages, then sbsettings (i had used "catagories" so i had to use sbsettings to unhide all my apps that were previously in folders on "catagories" now i got them all back. Hope this helps (^_^)
    2009-06-23 09:15 AM
  6. crakky's Avatar
    An easier way to do it, to fix ALL the problems, is skip restoring, just use redsn0w and re-jb. During the installation, don't check install Icy. Finish the install, then go into Cydia and update the critical stuff and it will auto install icy, but without all the problems.
    2009-06-23 09:54 AM
  7. Guido2424's Avatar
    I did what crakky suggested, worked great, fixed everything! Do it!
    2009-06-23 03:04 PM
  8. crakky's Avatar
    I did what crakky suggested, worked great, fixed everything! Do it!
    Awesome! Great to hear it worked!!
    2009-06-23 04:55 PM
  9. ethomson's Avatar
    I had the same issues (I had to install icy because cydia was hidden by categories and I needed icy to be able to download poof to unhide all my apps). Once I re-JB'd the phone cydia works like a charm. Thanks crakky for saving my iPhone from being destroyed by a wall.
    2009-06-24 12:16 AM
  10. crakky's Avatar
    I had the same issues (I had to install icy because cydia was hidden by categories and I needed icy to be able to download poof to unhide all my apps). Once I re-JB'd the phone cydia works like a charm. Thanks crakky for saving my iPhone from being destroyed by a wall.
    Ha ha glad to hear you didn't already throw it!
    2009-06-24 12:33 AM
  11. bencjedi's Avatar
    I have this same problem, but about fell over when I tried to re-jailbreak and got 3 bars on progress meter for loading ramdisk and then no movement for 15 minutes. I finally clicked cancel in Redsn0w and held the power button on iPhone down til it turned off, then powered it up and stared at the silver apple a few minutes before the springboard came alive (thank goodness).

    So for clarification crakky, do I need to go into iTunes 8.2 and do a standard 3.0 restore than re-jailbreak with Redsn0w? Or can I immediately just try Redsn0w again with the screwy Cydia dependency thing and it will overwrite the previous jailbreak firmware where I checked Icy like a knucklehead?

    Do you think I didn't correctly enable DFU mode in the last round trying to re-jailbreak in Redsn0w? That's my suspicion anyway cause I remember seeing a white background from a much longer duration on the first jailbreak. This recent attempt I barely saw the display turn white at all (it was a fraction of a second).

    thanks,
    ************************************************** ************************************************** ************
    6/24/09 - later

    Since no one replied to help I took a chance and it worked out. I just want to comment for the new person that stumbles into the trouble with their iPhone 3G. To answer my own questions:

    So for clarification crakky, do I need to go into iTunes 8.2 and do a standard 3.0 restore than re-jailbreak with Redsn0w? Or can I immediately just try Redsn0w again with the screwy Cydia dependency thing and it will overwrite the previous jailbreak firmware
    where I checked Icy like a knucklehead?
    Yes, needed to do a legit restore first.. I needed to go into iTunes 8.2, hold shift + click restore button (selecting iPhone1,2_3.0_7A341_Restore.ipsw). iTunes FAILED to restore with error code 1013, so I held power button down for 3 seconds, then pressed and held home button for 10 seconds, then released the power button after that 10 seconds and continued to hold the home button for another 20 seconds before releasing. This put the phone in DFU mode. Then I again held the shift key and clicked restore and again chose iPhone1,2_3.0_7A341_Restore.ipsw. This time my iPhone 3G restored perfectly (about 10-15 minute wait). I never once turned off iTunes when I was putting my phone in DFU mode for the legit restore in iTunes.

    Next I ran Redsn0w and ONLY selected Cydia this time, however after thinking I put my phone in DFU mode per the instructions in Redsn0w only 3 progress bars appeared as it was uploading the ramdisk to the phone. In an 'Oh crap' moment, I clicked cancel in Redsn0w and held the power down on my phone til it turned off. I started Redsn0w again and then this time (I think this is key).. when I was putting the phone in DFU mode, I continued to hold the home button until the iPhone's display turned solid white. This was several seconds after the uploading firmware part of Redsn0w kicked in (you could still see the timer had around 20 seconds left for holding down the home button as part of the DFU enabling part of Redsn0w). This time the progress meter moved all the way across the screen in Redsn0w and the jailbreak committed without a hitch.

    Do you think I didn't correctly enable DFU mode in the last round trying to re-jailbreak in Redsn0w? That's my suspicion anyway cause I remember seeing a white background from a much longer duration on the first jailbreak. This recent attempt I barely saw the display turn white at all (it was a fraction of a second).
    Yup, this seems right. I think letting go of the home button during the white screen is critical for Redsn0w to complete all the way.. otherwise it gets stuck and causes the user to worry they might be bricking their phone.

    I think restoring 3.0 legit is a good move to do first to ensure anything messy from Icy+Cydia is cleaned-out prior to Redsn0w.

    I hope my comments help instill some confidence about the particulars of the Redsn0w jailbreak process in Windows. Cheers!
    Last edited by bencjedi; 2009-06-25 at 06:21 AM. Reason: Automerged Doublepost
    2009-06-25 06:20 AM
  12. crakky's Avatar
    bencjediThanks for those instructions. I'm glad to see you managed to figure it out. In my case I did not do a full restore. I decided to skip it and re-jb with redsn0w. However, being a tweak, I messed around with Cydia too much and eventually got it to the point where it would not open on my ipod anymore. In that particular case, I did a full wipe of the ipod, installed 3.0 again, jailbroke with redsn0w and then restored my music and crap. Only in the case where I really screwed up would I consider doing a full restore. In any case, glad to see you managed to fix your problem!
    2009-06-25 08:19 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.