1. ihaveabu's Avatar
    I have a 3gs 3.01 JBed with Redsn0w 0.8. I used the 3.0 firmware to jb.

    I installed Cydia only through redsnow. I did not install Icy until after the JB.

    I'm trying to do a complete upgrade(cydia installer, dev-team, dtunes, and mobile substrate). This error happens when I update any software in Cydia, not just the main upgrades...

    These are the error messages I get:
    Error: Running Sub-process /usr/bin/dpkg returned an error code (1)

    then

    /var/cache/apt/archives/cydia_1.0.3032-64_iphoneos-arm.deb failed in buffer_write(fd) (8, ret=-1)

    I already restored and reJBed withouth installing Icy through redsnow and i get the same error....
    Last edited by ihaveabu; 2009-09-16 at 06:17 PM.
    2009-09-16 06:12 PM
  2. yodaddi's Avatar
    i too am having the same problem w/ my 2nd gen Iphone. i havent had this problem before. i jb'ed my iphone w/ Redsnow-win 0.7.2
    2009-09-16 11:43 PM
  3. ihaveabu's Avatar
    help anyone?
    2009-09-16 11:43 PM
  4. ihaveabu's Avatar
    help anyone?
    2009-09-18 04:23 PM
  5. spook75's Avatar
    I have a 3gs 3.01 JBed with Redsn0w 0.8. I used the 3.0 firmware to jb.

    I installed Cydia only through redsnow. I did not install Icy until after the JB.

    I'm trying to do a complete upgrade(cydia installer, dev-team, dtunes, and mobile substrate). This error happens when I update any software in Cydia, not just the main upgrades...

    These are the error messages I get:
    Error: Running Sub-process /usr/bin/dpkg returned an error code (1)

    then

    /var/cache/apt/archives/cydia_1.0.3032-64_iphoneos-arm.deb failed in buffer_write(fd) (8, ret=-1)

    I already restored and reJBed withouth installing Icy through redsnow and i get the same error....
    I removed Winterboard and Cydia worked fine afterwards.

    See my original post http://modmyi.com/forums/cydia-suppo...ml#post4958418
    Last edited by spook75; 2009-09-19 at 05:55 PM. Reason: added info
    2009-09-19 05:53 PM
  6. ihaveabu's Avatar
    just removed winterboard

    still getting teh same error when trying to update cydia and mobile substrate....

    now it says:

    unable to make backup link of ./System/Library/PreferenceBundles/CydiaSettings.bundle/icon.png' before installing new version

    wtf??
    2009-09-19 06:20 PM
  7. spook75's Avatar
    just removed winterboard

    still getting teh same error when trying to update cydia and mobile substrate....

    now it says:

    unable to make backup link of ./System/Library/PreferenceBundles/CydiaSettings.bundle/icon.png' before installing new version

    wtf??
    I have a solution posted in the original link above. Not sure if it's gonna help, but I wanted to let you know.

    Good Luck!
    2009-09-19 09:11 PM
  8. BlueRally's Avatar
    2009-09-20 04:51 PM
LINK TO POST COPIED TO CLIPBOARD