1. dochtml's Avatar
    Anyone have a solution for this problem. It started after the last cydia update. When I try to email a web link the URL doesn't get pasted into the email. Still have the problem even after the mobil substrate roll back.
    2010-03-21 10:02 PM
  2. novarain's Avatar
    I've ignored this error for quiet some time now because i could not find the solution at that time.
    Apperantly did not search hard enough. Followed the suggestions in the posts and it worked! Many thanks all!


    iphone 3G, firmware 2.2.1
    2010-03-22 08:39 AM
  3. fragger232's Avatar


    Here's a solution to get Winterboard working again:

    I just rolled back to Mobile Substrate 0.9.3005-1 (the previous version before all the errors) via AutoInstall. I SSHed using Fugu and copied in the mobilesubstrate_0.9.3005-1_iphoneos-arm.deb to /root/Media/Cydia/AutoInstall/. Make sure you set permissions to 0755. Then reboot and dance (optional).

    And now the combination of all three below works like a charm.

    Winterboard 0.9.2993-1
    Mobile Substrate 09.3005-1
    Cydia Installer 1.0.3044-65

    Good Luck!
    ummm how do i do this exactly cause i have no idea what SSH or Fugu is. please explain Y_Y
    2010-03-25 01:12 AM
  4. HARIBOKLAAS's Avatar
    Same thing here, can anyone please explain it step by step? =p I really have no idea what everyone is talking about... root/Media lolwut, SSH? FuGu? WINScp? If you could help, it would be very much appreciated,

    thanks in advance
    2010-03-27 08:58 PM
  5. dochtml's Avatar
    Found a solution for problem with no web page links when trying to email them. Turn off mobile substrate addon for this option under sb settings. Must be problem with version of sb settings and older mobile substrate version. At least I can email web links now.
    2010-03-28 01:08 PM
  6. 4ntimatter's Avatar
    hey guys

    I've got the exact same problem as Rosemary. Ipod Touch 2g 2.2.1. Model MB

    Just jailbreaked worked perfect installed some theme thing. ipod got stuck on start up, had to do scenario DFU mode which fixed it so all I did was install winterboard.

    I understand spook75 mentioned how to fix it, but i'm not sure how to do what he said so if spook or any of you could take the time to explain I'll come over to your house and do chores. but srsly i'd be so grateful guys. I've been two days now with this problem and It's driving me bananas!

    Thanks alot for even listening to another moanbag that hasn't a clue.

    My errors were:

    When I open Cydia:

    Error: Refreshing Data
    Method http has died
    unexpectedly!

    Sub-process http received signal 9.

    Method /usr/lib/apt/methods/http
    did not start correctly

    Method http has died
    unexpectedly!

    Sub-process http received signal
    "cant see the rest cause it freezes if I try to scroll so I have to click Okay!

    Also I'm getting an error on Installer: Error unable to decode trusted sources info and when I click ok I get: Error unable to decode source at ripdev.com and in sources both Rip Dev and another source called Incalid Source have red exclemation circle.


    When I try to remove winterboard I get error: Running sub-process /usr/bin/dpkg exited unexpectedly

    Thanks again.
    Last edited by 4ntimatter; 2010-04-11 at 05:15 AM.
    2010-04-11 03:43 AM
  7. chaulklet's Avatar
    4ntimatter do you still need help? i figure it out today
    2010-04-12 12:08 AM
  8. 4ntimatter's Avatar
    yes mate. Thank god I've sat here at the pc screen and haven't even eaten or gone to the bathroom since I posted.

    lol kidding but yes mate thanks.
    I found a vid on you tube that told me to go into safe mode. So had to re jailbreak cause I couldn't delete winterboard.
    Then I had to install cydelete spsettings and then winterboard, I can now download but it has to be in safe mode.
    So if there's another way so's I don't have to be in safe mode I'd love to hear it.

    But my main problem is installer now. I still haven't found away to fix it. error unable to decode trusted sources. when I hit ok I get Unable to decode source at http//i.ripdev.com/

    Sorry for the long post and thanks for taking the time. Even if you can't help I appreciate the effort.
    2010-04-14 06:23 PM
  9. chaulklet's Avatar
    oh since you got it to work then i guess not -.- but if you still need help do what spook said to do, go get the old mobile substrate. the link was provided by someone else. dont use installer. it doesnt work. if you want free apps. go into source and put hackulo.us and then get insatllous from there
    2010-04-15 12:43 AM
  10. 4ntimatter's Avatar
    cheers mate. I was just wondering do you have to be in safe mode for cydia to work, and for you to be able to download. And I got hackulo. thanks a bunch.
    2010-04-15 01:47 AM
  11. chaulklet's Avatar
    well i didnt use safe mode i just got the old version of the mobile substarte and it works fine now
    2010-04-16 03:02 AM
  12. 4ntimatter's Avatar
    Thanks guys. I'm just chancing my arm but can anyone explain how to roll back and what I need to install to do it.

    Cheers guys.
    2010-04-16 05:29 PM
  13. Chaotican's Avatar
    Ok it took me MANY tries and countless resets, but after fighting with the same issue for a long time, I was finally able to get Spooks advice to work.

    Previously linked in this thread is a link to an index of debs. I went there and downloaded mobilesubstrate_0.9.3005-1_iphoneos-arm.deb.

    Then on a fresh restore and jailbreak on my ipod touch 1st gen running 2.2.1, I ran Cydia and let it do all of its updates.

    Afterwards, I searched for "openSSH" and "Mobileterminal" on Cydia and installed both of those on the ipod. Afterwards, I searched for WinSCP (since im a windows user) and installed it on my PC. Heres a link to the tutorial on how to connect with it.

    SSH on Windows - ModMyi - Wiki

    For ease of simplicity, I renamed the .deb file to something shorter and easier to manage, and copied it over into "/var/root/" via WinSCP onto the ipod.

    Afterwards, I ran the mobileterminal on the ipod. After it comes up I entered: "su" followed by the same password used for WinSCP "alpine".

    Afterwards, I typed: "dpkg -i /var/root/filename.deb" to install the the older version of mobilesubstrate (Again ver 0.9.2005-1)

    Afterwards I was able to install whiteboard without it breaking future downloads with the newer version of mobilesubstrate.

    Sorry if this is at all confusing, but it is late and ive been working hard at this. Ive tried to lay it all out as I can recall from the last working attempt. I sure hope this helps...
    2010-04-24 09:50 AM
  14. Bani-mio@hotmail.com's Avatar
    Hi,

    For several hours my iPhone has been frozen on the Cydia: Refreshing Data that my friend touched by mistake. I tried to press: Cancel, OKay, I tried to used the home button and the on/off button with NO success.

    Please help!!! I am desperate now. Thanks!

    Please help, I don't know what to do. For several hours, my iPhone has been frozen "Refreshing Data" from Cydia. My friend touched the Cydia Icon by mistake and I had been without a service for several hours. Nothing works, I tried on/off button, home button, okay, and cancel and the phone does nothing. Please email me any suggestions at: [email protected].

    Thanks!!!
    Last edited by [email protected]; 2010-05-26 at 12:38 AM. Reason: Automerged Doublepost
    2010-05-26 12:38 AM
  15. wolverine3344's Avatar
    you guys are simply AWESOME! First time jailbreaking an Ipod Touch 2G 2.2.1 fw and ran into this program. You guys rock! Keep up the good work! (especially you Spook75)

    P.S. Just to clarify what i did: I ran Cyder to be able to install OpenSSH since Cydia wouldn't let me do it. After that i went to the Index of debs, grabbed the old version, change my permissions on all folders to 0755 and let the magic happen! Awesome!
    Last edited by wolverine3344; 2010-06-10 at 07:40 AM.
    2010-06-10 07:35 AM
  16. plaguedbyiphone's Avatar
    "I just rolled back to Mobile Substrate 0.9.3005-1 (the previous version before all the errors) via AutoInstall. I SSHed using Fugu and copied in the mobilesubstrate_0.9.3005-1_iphoneos-arm.deb to /root/Media/Cydia/AutoInstall/. Make sure you set permissions to 0755."

    I don't have wifi. Can I roll back to older mobile substrate version with DiskAid or iPhonebrowser?
    2010-06-23 01:06 AM
  17. lakerzfan27's Avatar
    guys i did what spooky said but my cydia is still having the refreshing data error... the thing is i have phone 3g 3.0..

    so what do I do or what mobile substrate version do i install?
    2010-06-23 08:25 PM
  18. Tatie five0's Avatar
    Same here. Same problem and I would love someone to tell me how to fix it thanks!!!

    I'm having the same problem as them tell me what to do
    Last edited by Tatie five0; 2010-08-11 at 11:07 PM. Reason: Automerged Doublepost
    2010-08-11 11:07 PM
  19. jayjayjayjums's Avatar
    Hey all- I'm in the same situation except I just jailbroke an iPhone 3g (4.0.2 firmware, JB'd using RedSn0w) for the first time, so I don't have any of these apps that might help me fix the problem... OpenSSH, DiskAid etc.

    And since the error is preventing me from using Cydia to find and install these apps, I'm in a bit of a bind here. Hope someone can help me out, thanks much.

    Edit: Ah, just realized Disk Aid is a desktop app.
    Last edited by jayjayjayjums; 2010-10-04 at 10:20 PM.
    2010-10-04 10:14 PM
  20. sergiu23's Avatar
    Guys this is how i removed winterboard (all other methods failed)

    - got iphone explorer 2.1 (free)
    - connected iphone to pc via cable
    - open iphone expolrer
    - go to apps -> winterboard , and select winterboard and delete the entire folder
    - go to cydia and uninstall winterboard, no more errors and it will uninstall

    good luck!
    2011-02-22 11:07 PM
40 12
LINK TO POST COPIED TO CLIPBOARD