1. kingcodez's Avatar
    I've been doing this for about 10 hours now, I've read almost every fix and tried but to no avail.

    First I was running 3.0, on a 8gb 3G, and I decided that the slowness was pissing me off and that it was time to upgrade.

    I researched which FW to use, then discovered that PWNagetool strips out the baseband update, so I selected 3.1.3 and went from there.

    I made my custom FW, cydia, slipped in SSH and Terminal, and a few sources, tied it up and spit out a good image. I stuck it on my phone through itunes, everything was good. Open Cydia and it want's two updates, fine. What it wants is apt 0.7 (apt-key) 0.7.25.3-3 and apt 0.7 strict (lib) 0.7.25.3-7

    So I do it why not. Anyways, I'm on wifi, on my network, which IS working, and I keep getting these ERROR apt.saurik.com host not found, cache error, about 15 of them pop up for me to click through. That was 10 hours ago.

    I re installed a NEW FW maby 5 times, went to 3.1.2 same issue, Did a naked FW with JUST cydia, nope. My baseband before was 4. something, I read about blackra1n, so I upgraded through itunes to a vanilla 3.1.2 FW, my baseband is now 05.11.07 which IIRC is still unlockable. With this vanilla FW, I used Blackra1n, JB'd the phone, opened the ra1n app. and I get network errors, It can't download the packages to unlock or install cydia.

    I reset my network settings 5 times, rebooted, turned on airplane mode, rebooted some more, reinstalled 3.1.2 and blackra1n'ed again, nothing. I went back to my custom 3.1.2, my naked 3.1.2, then my custom 3.1.2, cydia on all accounts, from maby 6am est to 4am est still errors, I slept then tried again now, still a no go.

    I SSH'd into var/lib/apt/lists and deleted everything, ok so now cydia dosen't want an update, good. I added repo666.ultrasn0w.com, went ok. I can't get ultra because it's dependant on some mobilesubstrate thing. So deleting that stuff dosen't work, plus it's added again once I try to update.

    I've tried deleting cydia and reinstalling manually, no go. I SSH'd around and did a lot of things I googles but nothing works. I just made a 3.0 firmware and I'm going to try using that. But I don't think it'll work.

    I read that our boy Saurik released a little update maby two weeks ago, I think this is my problem.

    I've scoured the internet looking for solutions, googled every phrase I've come across, I even installed windows on another macbook of mine, so I couse use cyder to download it manually, but it didn't work. I got all sorts of errors in the program.

    Apt-get commands don't work in terminal (on the iphone) I think I researched this, it's due to it not being present because erica's utilities, or some other 'aftermarket' cydia app isn't installed. If I can't download anything in cydia I have no way of installing that or using Apt-get.

    It's going to be maby 4-5 days until I have the money to buy a factory unlocked 3GS, I like in China and I'm getting a HK unlocked one, simply because I was sick of jailbreaking but now it seems necessary as I'm having so many problems here.

    I've read maby 50 tutorials and all 50,000 comments, most are people saying 'you need wifi for cydia to work' or other stupid stuff. I really am in need of help, I've never seen this problem. I tried to hold off on posting and searched and googled but nothing.


    SO:


    Actually I don't think I used 3.1.3 I went with just 3.1.2 I can't find the old 3.1.3 file on my HD so yeah.
    Again my baseband is 05.11.07 which was just upgraded with 3.1.2 from a 4.26.xx baseband. I tried the unlock and everything on BOTH basebands before changing either. Blackra1n's blacksn0w dosen't work, no network connection, googled problem, network reset dosen't fix. Deleting source lists with SSH dosen't work either. Every fix I've seen I've tried on multiple restores, and on different FW versions.

    Please let me know if anyone can figure this out.

    I just had an idea that maby it was china blocking iphone internet requests to cydia or ra1n servers, so I connected my MBP to the ethernet, turned on my VPN to a dallas TX server, shared my internet to the wireless card, connected to that with the iphone, tried it, still no go, setup a hotspot shield free VPN, and itshidden.com's VPN, both still don't work. So it's not that either.
    Last edited by kingcodez; 2010-03-16 at 11:55 AM. Reason: Automerged Doublepost
    2010-03-16 11:55 AM
  2. ProgramErrorX's Avatar
    to get the apt-get commands working people say you need the aptitude package form cydia but i'm sure you can find it on the internet and try reinstalling that way if you get it and need to know how just send me a message
    2010-03-18 12:49 AM
  3. saadshishani's Avatar
    hi,

    a none related question
    where to buy an officially unlocked iPhone from chine?

    plzzzzzzzzzzzzz
    thanx
    2010-04-07 10:45 AM
  4. petoria's Avatar
    i just recently downgraded a friends 3g from 3.1.3 to 3.1.2 on baseband 5.12 and cydia is giving the cache thing and he can't update the essential update that's showing. Anyone know how this can be fixed? He doesn't need an unlock b/c he's got ATT. Just need to update cydia
    2010-04-07 10:42 PM
LINK TO POST COPIED TO CLIPBOARD