1. jdungp's Avatar
    I deleted cydia on my 3gs 32GB version 3.1.2(7D11. Can someone please help me get it back on my phone?
    Thank you.
    2010-03-17 02:06 AM
  2. moon#pie's Avatar
    Rejailbreak and just tell it to install cydia. Use redsn0w.
    2010-03-17 02:08 AM
  3. kingcodez's Avatar
    Google manually install Cydia, If you know how to SSH and installed SSH before you deleted cydia you can download cydia's app and drop that in, then in terminal give a command to install the software.
    2010-03-17 06:25 AM
  4. ProgramErrorX's Avatar
    you don't need to rejailbreak if you have the ssh stuff. i had the same problem and know how to fix it. if you have ssh you need to go into whatever you use and run the terminal in WinSCP you go to command->open terminal now you have to type in:
    apt-get remove cydia and press enter when it says to type in Yes, say as I do! type that in and press enter.
    now type in apt-get install cydia and press enter if it says the do as i say thing again just do that. wait for it to finish and respring your iPhone. And that should get it back if it doesn't like it did on mine you need to do this.

    open the terminal and type
    apt-get ugrade
    let that run when it stops at any step respring and see if that fixed it if it doesn't type in
    apt- get remove cydia
    let that run and when it stops at any step run the command
    apt-get install cydia
    let it run when and if it stops at any step respring and see if that worked if it doesn't try this process a few more times and if it stil doesn't work the way i got it was by downloading the .deb file put it on your iPhone and run the command
    dpkg -i /tmp/mobileterminal_316s-7_iphoneos-arm.deb
    wait for that to finish (it will install mobile terminal) after resprining when it stopped at one of the steps i resprung and everything was there cydia and mobile terminal if that doesn't work but it did get you mobile terminal try the process with mobile terminal and if that doesn't work then rejailbreak

    Here is the link
    Last edited by ProgramErrorX; 2010-03-18 at 12:54 AM. Reason: Automerged Doublepost
    2010-03-18 12:54 AM