1. revmitcz's Avatar
    Starting about 3 days ago, my iPhone was acting strange - random restarts, slow to restart, slow to respond, WiFi not turning on, etc.

    The only thing that changed around that time was that I ran an update on Cydia (it updated core Cydia files and it updated Cydget).

    About a day later, I was having issues where my iPhone would start up to a competely white screen (which I assumed was the one-and-only Cydget app I installed for a "flashlight"). Once I was able to get iTunes to actually recognize it, I restored from a backup (which was only a few days old, at most, so it would've had all the same apps/jailbreak/cydia updates) and everything seemed fine.

    Last night, it began acting up again and doing the random restarts and white screen stuff. This time, iTunes wouldn't recognize it and I couldn't get the phone into recovery or DFU mode. A few minutes later, it just.. stopped responding entirely.

    I charged it (via a wall charger) over night and not once today have I been able to even get the white screen. It's absolutely not responding in any way.

    I've tried home+power, home+power+volume up, home+power+toggling the silent switch, home+power+toggling the volume, holding the power button for an hour straight (used a piece of tape for that), plugging it into the dock while holding any of the aforementioned buttons... nothing gets any response whatsoever. Just the dead, black screen.

    I've been hoping all day that the battery will just drain and hopefully that'll give me the chance to plug it in and start over. I don't even care if it's not jailbroken anymore - I just need to be able to make/receive calls and text messages at this point.

    Does anyone have any suggestions?

    Do you think Apple would help me if I brought it into a store? (I of course wouldn't mention it was jailbroken until they got the thing to at least show a sign of life)

    Has anyone had similar problems before?

    Thank you ahead of time for any and all help/advice you might be able to give.
    2010-03-23 11:08 AM
  2. hanley111's Avatar
    Mine did the same thing. I called Apple and told them that I have the same problem u r ha ing. It was new enough that I bought the extened repair program and they sent me a new one. It had 3.1.2 on it till I updated when it asked for it without knowing what it would do.
    Hope this answers yr ?
    2010-03-29 04:12 AM
  3. revmitcz's Avatar
    I just went into the Apple Store and told him what happened (leaving out, of course, that it was jailbroken). They gave me a new one on the spot and I restored it from my last good backup on the old iPhone.

    Oddly enough, it says it's using 3.13 even though I never updated the old one to that and my backup would've been for 3.12. I haven't tried jailbreaking this one, cause I'm not sure if I'm using a "new world ROM" - my last one was bought on the first day of 3GS release.

    Ehh well. I'm just happy to have a working iPhone for now. I'm not rushing to JB it any time soon.
    2010-03-29 04:26 AM
LINK TO POST COPIED TO CLIPBOARD