1. davedke's Avatar
    I used spirit in XP to jailbreak my ipad and it said it was successful. I have the cydia icon on the springboard. When i try to start it, it starts opening and crashes before ever getting into cydia. I even tried a restore in itunes and still same thing after a jailbreak. I tried to change the compatability but then I get "itunes 9 is needed to function". That message does not come up if I don't mess with compatability and the jailbreak goes through without any errors but cydia won't open. Help please. Thanks
    Last edited by davedke; 2010-05-04 at 07:17 PM. Reason: better title
    2010-05-04 06:42 PM
  2. askunk's Avatar
    Hi! I've got a friend of mine who was so glad he could finally JB his iPhone 3 GS with 3.1.3 OTB.

    Spirt was great.... 30 secs and it was done, but unluckily he got stuck there as Cydia quits unexpectedly a few instants after opening. It is not the high load on Saurik's server, 'cause it quits so fast it couldn't even try to access the net.

    It is clear that it's a Spirit JB bug and apparently there is no way to download and reinstall Cydia manually.

    We tried restoring the iPhone with itunes, repeated the JB before and after syncing the iphone, but no attempt has succeded.

    Any suggestion? He did it on Windoze XP too.


    2010-05-05 01:25 AM
  3. davedke's Avatar
    It sounds like your friend and I have the same problem. I just downloaded spirit fixer by kirma and still no luck when I change compatability. Still says I must have iTunes 9. If I dont change compatability it goes through but cydia doesn't start.

    Does anyone have any ideas on how to fix this issue and/or get spirit to work?

    Got it to work last night on different computer also on XP. Didn't change the compatibility at all
    Last edited by davedke; 2010-05-05 at 03:46 PM. Reason: Automerged Doublepost
    2010-05-05 03:46 PM
  4. shavi's Avatar
    Hey guys I have the exact same issue only that I run spirit on a Mac...cydia opens for less then a sec and crash...that's really shity!!
    Please ppl come with a solution!
    2010-05-14 12:28 AM
  5. mclean's Avatar
    My problem sounds very similar. I was able to jailbreak my 3.1.3 3GS MC model with Spirit using Windows XP. Cydia opened and I tried to add a repo when I lost connection. The screen froze indefinitely so I rebooted the phone. Since then Cydia won't open for more than a split second.

    I would also greatly appreciate any help.

    Thanks again!
    2010-05-24 10:04 PM
  6. jainiery's Avatar
    I had the same problem as you guys... I open cydia and even before loading it crashed,I rebooted my ipod for about 10 times but it didnt work...i also used spirit but with Windows 7...

    so to fix that problem you would need iFile or any others apps or program that you can use to navigate to your file system in your device...

    1. Using iFile i went to /var/lib/apt/lists .. then i delete all the ffiles in that folder except for the partial folder and than i reboot my device...it was suppose to work but it didnt so then

    2. i went to /var/lib/dpkg/updates and delete all files in that folder...reboot the device and cydiaa was working again....

    Try # 1 first, if doesnt work then try #2
    2010-05-29 03:59 AM
  7. askunk's Avatar
    It's not about working AGAIN

    Cydia has NEVER worked, thus we couldn't install SSH... How can one access an iPhone without OpenSSH?
    2010-05-29 01:45 PM
  8. Deeecent's Avatar
    Same problem. I jailbroke with spirit and everything was good. then i downloaded one theme and cydia wont open after that. Is there any way to access the files through your computer? well i know there is.. but how.
    2010-06-01 04:34 PM
  9. askunk's Avatar
    Not properly the same problem... my friend has still an iPhone which is not completely jailbroken, since he could not launch Cydia, not even once!

    At least you have your last resort: rejailbreak... He can't even do it, Cydia won't work!

    2010-06-01 04:57 PM
  10. bigbadjono's Avatar
    As mentioned earlier, but in a a very subtle way, try a different machine to JB it on. I did and it worked first time.

    This may be due to minor amounts of corruption across the data transfer cable, as from one PC my sync with iTunes sometimes corrupts video/photos, but on the other (the one which JB perfectly) I have never had a problem.
    2010-06-09 06:54 PM
  11. kys's Avatar
    Did anyone try to restore iPhone and then re-jailbreak?
    2010-06-09 08:10 PM