User Tag List

  1. gedster314's Avatar
    I have an Iphone 3gs, Ipad wifi and Ipad 3g. All are jailbroken with Spirit. I regularly scp and ssh into the iphone and ipad wifi. I just got my ipad 3g (just in time to get the unlimited data). My problem is that I can not ssh into the ipad 3g. I have uninstall and reinstalled openssh from both Rock and Cydia. I have done a full DFU restore and rejailbroken and still can not get it to work. When I installed SBsettings the SSH toggle does not show up but it is turned on in SBsettings settings. I can not get mobile terminal to run so I can not manually start openssh.

    Anyone see this? Anyone have suggestions? Sorry if this was posted before, I did do a search here and on google.

    2010-06-09 06:22 AM
  2. battlecrushr's Avatar
    I'm pretty sure to connect to a device in ssh. Both the device and the computer need to be on the same wifi network and since ipad3g can't connect to wifi. U can't ssh that way. However maybe there's ssh over USB like ifunbox. But I don't know if It supports ipad
    2010-06-09 06:46 AM
  3. gedster314's Avatar
    Thanks for the reply.

    The 3G is on the same wifi network but even if not on the same network, I could ssh into it with my public ip if openssh was running.
    2010-06-09 07:46 AM
  4. Imahottguy's Avatar
    I want to help, but am stumped! Try this perhaps

    Install OpenSSH
    Turn off iPad via the slide to power down (right way)
    Turn back on, and see if it works. Sometimes a reboot may help, but I don't know... Sorry if this doesn't help...
    And it will be like a taco inside a taco within a Taco Bell that's inside a KFC that's within a mall that's inside your dream!
    2010-06-09 11:29 AM
  5. katmeef's Avatar
    Openssh worked over wifi on my iPad 3G when I had it installed (I've since removed it as it was causing screen calibration issues)
    2010-06-09 06:38 PM
  6. gedster314's Avatar
    Well, after playing with different things, I finally got it working. Not quite sure what did it but I installed the beta version of SBsettings and then unintalled openssh for like the sixth time and it started working. I can't imaging that Sbsettings was the issue since It worked on the iPhone and ipadwifi flawlessly.

    I have not noticed the touch calibration issue people are mentioning but I have been using my wifi iPad for over a month with openssh and no issues. I do notice that my 3G one with perfect browser seems to be a little flakey. Let me play with the 3G on some more with Astro browser and safari and see.

    I don't know if I like the 3G service on the iPad. Lately latency has been horrible in my area, 2000-3000 ms. It's almost to the point where I want to carry my Sprint WinMo phone as wifi router. And people thought I was crazy for keeping my Sero account on Sprint. My Mogul with a huge battery sure does come in hand as router and it only costs me $23 a month with corporate discount. If the att network doesn't improve I'm going to ditch the 3G and the iPhone and just keep the iPad wifi. Sorry for the rant.
    2010-06-09 08:38 PM
  7. Imahottguy's Avatar
    I've had SSH running on my ipad since Spirit became available, and have never had issues with 3G, or screen calibration. On the note about AT&Ts network being slow, I read somewhere that they plan to have their 3G covering some 250 million people by the years end. So that should hopefully help you out. Good thing it is prepaid right?
    And it will be like a taco inside a taco within a Taco Bell that's inside a KFC that's within a mall that's inside your dream!
    2010-06-10 05:51 AM
  8. FerrariCUBU's Avatar
    I'm using OpenSSH on my iPad with WiFi + 3G and the only problem I've had with it is this:

    - I turn it off (not sleep, off).
    - I turn it back on and the WiFi symbol is not visible, but I'm still connected.
    - I respring and the symbol reappears.

    It's not a huge problem, just thought I'd mention it.
    2010-06-12 03:45 PM