1. ElectricEnix's Avatar
    I try to downgrade using iTunes but every time I do the SHIFT+RESTORE to click my 3.1.2 or 3.1.3 firmware it says Its not compatible or something like that.

    Can anyone help me downgrade my iPod Touch 3G thats on 4.0.

    All I want to do is downgrade. =[
    iPhone 3G/4/6Plus | OS X | PS3/4-PSN: Cenix13xpe
    DeviantART Twitter Twitter II
    2010-07-21 04:04 PM
  2. lol_release's Avatar
    2010-07-21 04:17 PM
  3. diegovengeance's Avatar
    I heard apple does let you downgrade to any of the old software. That's why I'm still waiting for a jailbrake. If you find something let me know.
    2010-07-21 05:24 PM
  4. ipod_guy's Avatar
    you need shsh blobls for 3.1.3, or if you have a non mc model use redsn0w to downgrade otherwise you'll have to downgrade to 3.1.2

    I heard apple does let you downgrade to any of the old software. That's why I'm still waiting for a jailbrake. If you find something let me know.
    correct they don't thats why they are always telling us to backup our shsh blobs
    2010-07-22 12:04 AM
  5. bluerocker's Avatar
    dude, just use spirit to jailbreak, its easy as pie (even though i have no idea how to make pie)
    2010-07-22 05:24 PM
  6. ElectricEnix's Avatar
    dude, just use spirit to jailbreak, its easy as pie (even though i have no idea how to make pie)
    Nah, its ok.

    I head the New Spirit is coming for 4.0 and 4.0.1 so Ill just wait for that.
    iPhone 3G/4/6Plus | OS X | PS3/4-PSN: Cenix13xpe
    DeviantART Twitter Twitter II
    2010-07-22 06:18 PM
  7. Wepster123's Avatar
    Go download 3.1.2 from a different site
    2010-07-25 10:43 PM
LINK TO POST COPIED TO CLIPBOARD