1. RickyEarl2034's Avatar
    Hi, was hoping someone at this fine forum could diagnose the issue I'm having with Categories.

    I'm running 3.2.1 on the iPad, jailbroken with jailbreakme.com. In a nutshell, whether I run Categories with or without the SB plugin, the same thing happens. Folders I create in Categories do not show up in the Categories "Edit" pane, but they show up on the Springboard. Since they don't show up on the Edit pane, I cannot add to them or delete them (even when I unistall Categories). Each time I open Categories, it thinks it's the first time and gives me the About Categories "know what you're doing" popup.

    Here's a video of what's happening. Sorry about the wobblies and the accidental launch of CinexPlayer:

    [ame=http://www.vimeo.com/14071525]Problem with Categories on iPad on Vimeo[/ame]

    I have tried respringing, reinstalling both Categories and Categories SB, just installing Categories, rebooting the iPad and even restoring and re-jailbreaking. Pretty much in every combination I can think of, too. No change.

    Anyone know what's going on?

    Last edited by RickyEarl2034; 2010-08-12 at 12:42 AM.
    2010-08-12 12:36 AM
  2. DaveiPhone's Avatar
    I had a similar issue, which I finally figured out was caused by a Rock update screwing up permissions. If you have Rock installed, try running the Rock Permissions Fix from Cydia. That did the trick for me.
    2010-08-12 08:41 AM
  3. RickyEarl2034's Avatar
    That makes sense. But for some reason I don't have that Rock Permissions Fix package listed in Cydia. I'm set to Developer and I manually refreshed the package list. I know this is a stupid question, but what am I missing?


    Well, I'd still like to know why the Rock Permissions Fix wasn't showing up in Cydia, but I found Rock Permissions Fix on the net, put in Dropbox and made it a favorite (so a local copy was downloaded to the cache), and then used iFile to install it.

    It worked! Thanks!

    But now I have a new issue. For several of my apps (Urbanspoon, OpenTable, Maps, Toy Story, Contacts if it matters), the icons don't show up in the list when I choose what to put in folders, and they show up with white blank icons when I put them in folders). I have no themes or custom icons at all on the iPad - these are the stock icons).

    Any idea why this new issue is happening?

    EDIT -

    OK, fixed the white icon problem. What's weird is that when you are choosing apps to go into a folder in Categories, several apps in scroll-down list have no icons at all. Those would show as white icons in a Categories folder, but got their icons back when taken out of the folder.

    I followed some instructions on rebuilding the com.apple.mobile.installation.plist by deleting it, then adding an app with icon from Cydia and the AppStore. This fixed the problem in the folders.

    The weird thing is that when you go into Categories and choose apps for a folder, these same few apps still don't have any icons in the list. But they have icons when you look at them in the actual folder on the Springboard.

    Oh, well. All's well that ends well.
    Last edited by RickyEarl2034; 2010-08-12 at 10:03 PM. Reason: Automerged Doublepost
    2010-08-12 10:03 PM