1. Dan4VT's Avatar
    Today after a respringing of my iPod Touch 3g, my device went into safe mode. I did not install anything or do anything to it beforehand...A game caused the device to hang up so I resprung it.

    After respringing it again after going into safe mode, all of my apps were funky. My categoriesSB wasnt working properly...my device showed all of my apps rather than just the homescreen of folders like normal. The folders were there, and they opened, but there were 12 other screens of apps.

    Next, SBSettings, Infinidock, etc. didn't work, and pretty much nothing else in the background will work. When I scroll to cydia, it loads up just fine, downloads apps just fine, etc. Many other jailbreak apps work fine also (winterboard, ifiles, etc).

    I tried reinstalling categories and categoriesSB...nothing. I tried reinstalling mobilesubstrate.....nothing.

    Any idea what is causing this?

    Also, I am running iOS 4.0. I made sure NOT to update to 4.0.2. When I check the info on my ipod touch, it says I am running iOS 4.0. iTunes also says I am running iOS 4.0. BUT, in cydia it says at the top that I have SHSHs saved for 3.1.2, 4.0, and 4.0.2. WHAT IS UP WITH THAT? I never installed it!!! Everything else says I am running 4.0.

    WEIRDNESS. Help me restore order to my poor iTouch 3g!
    2010-08-26 08:48 PM
  2. axiomjunglist's Avatar
    It's CategoriesSB. Uninstall it and reboot. You'll be back to normal. I like that program but it has a lot of problems...
    2010-08-26 10:13 PM
  3. Dan4VT's Avatar
    Unfortunately that didn't do anything. When I uninstall it and restart the ipod touch it is just the same as it was before. None of the jailbreak apps shows up in settings, SBSettings doesnt run, infinidock doesnt run, winterboard themes do not work, among other things.

    The weird thing is that when I load up jailbreak apps like winterboard, cydia, rock, ifile, etc, they open just fine.

    Any ideas?
    2010-08-27 01:31 AM
  4. axiomjunglist's Avatar
    It sounds like something using mobile substrate, so it won't affect jailbreak apps like rock or cydia.

    I'd download crash reporter from cydia. It will take some sleuthing scanning through system and crash logs but sometimes the culprit is easy to spot...
    2010-08-27 01:49 AM
  5. Dan4VT's Avatar
    Problem solved! I was reading up and discovered that it was mobilesubstrate that was the issue. I went into cydia and viewed my packages in the advanced mode (by tapping the "simple" button in the top right of the screen) and went to mobilesubstrate. I then selected "modify" and "reinstall." I rebooted my device and there you have it....fixed.

    I hope this can help some others out there.

    __________________________________________________ ______
    New Update as of Now...

    Not everything is back to normal.

    Now, when I try to change volume with the volume buttons it causes a crash. I initially thought it would be glovepad, so I uninstalled it. Once the device restarts and I try to change the volume via the side buttons, it causes another crash.

    Last edited by Dan4VT; 2010-08-27 at 07:37 AM. Reason: Automerged Doublepost
    2010-08-27 07:37 AM