User Tag List

  1. jcampbell666's Avatar
    Hey guys,

    so basically my girlfriend asked me to jailbreak her ipod touch. little did i know that it was running a 2.2 firmware. (2nd Gen)

    My goal is to have it running on iOs 4, and jailbroken.

    I currently cannot even jailbreak it on 2.2, quickpwn doesnt seem to be working.

    I am up for anything, post your ideas or comments please!!!!
    2010-09-08 01:38 AM
  2. Simon's Avatar
    You should be able to just download the 4.0 firmware for it, shift click restore in itunes and point it to that firmware. Once on 4.0 you can just go to jailbreakme.com in safari and jailbreak.
    2010-09-08 01:42 AM
  3. MuseFan288's Avatar
    didnt apple stop signing 4.0 and up on the 2nd gen?
    2010-09-08 02:19 AM
  4. Simon's Avatar
    I don't think uses the regular SHSH like a 3GS or iPhone 4, he should be able to restore it I believe (not 100% on this though as I am not as knowledgable about ipods but it doesn't hurt to try.)
    Last edited by Simon; 2010-09-08 at 02:24 AM.
    2010-09-08 02:22 AM
  5. jcampbell666's Avatar
    yea they wont sign 4.0 on the touch either
    2010-09-08 03:47 AM
  6. Bluemoldycheeze88's Avatar
    4.0.1?...
    2010-09-08 04:25 AM
  7. jcampbell666's Avatar
    any other ideas guys?
    2010-09-09 04:05 AM
  8. MuseFan288's Avatar
    upgrade to 3.1.3
    try using the tiny umbrella programs. i saved SHSHs for firmwares i wasn't on or was ever on. spoofing the firmware to make the ipod think it's 4.0 also works to save your shsh with cydia.
    2010-09-10 03:14 AM
  9. SnR's Avatar
    yea they wont sign 4.0 on the touch either
    His iPod doesn't need signing. You should just be able to update to 4.0 or 4.01 and jailbreak with jailbreakme.com.
    You could also update to 4.1 for Game Center, as the old bootrom devices can be jailbroken on all firmware.
    2010-09-10 04:07 AM
  10. MuseFan288's Avatar
    His iPod doesn't need signing. You should just be able to update to 4.0 or 4.01 and jailbreak with jailbreakme.com.
    You could also update to 4.1 for Game Center, as the old bootrom devices can be jailbroken on all firmware.
    they stopped signing for 4.0 on 2nd gen. he can still go to 3.1.x but not 4.0 he would have to go to the latest.
    2010-09-10 05:28 AM
  11. SnR's Avatar
    I stand corrected. Thanks for that.
    2010-09-10 05:39 AM
  12. MuseFan288's Avatar
    no problem mate. fortunately 3.1.3 doesn't need signing. spoofing the firmware should save his shshs with cydia.
    2010-09-11 02:30 AM
  13. Simon's Avatar
    Spoofing the firmware has nothing to do with how SHSH are saved. SHSH can only be saved for a certain firmware when apple is still signing that firmware, it does not matter what firmware the device is actually on or spoofed to be on.
    2010-09-11 02:38 AM
  14. jcampbell666's Avatar
    so what should i do guys?
    2010-09-12 12:45 AM
  15. ddoolin's Avatar
    so what should i do guys?
    You should be able to upgrade to the latest FW version and still be able to JB with that particular generation of iPT.

    @x98car: Yes, it does matter what firmware you're on when you save your SHSH. I can't just spoof my iPhone down to 4.0.1 just because I have an SHSH saved from 4.0.2 or the like. Unless you meant something else...?
    2010-09-12 02:45 PM
  16. Simon's Avatar
    No it does not matter what firmware you are on when saving your SHSH. A SHSH is saved by requesting a restore to a particular firmware from Apple. If Apple is still signing a firmware then that SHSH can be saved, regardless of what firmware your iphone is actually on. I could have an iPhone on 3.1.3 and use tiny umbrella to save my SHSH for 4.1 (because that is the firmware that Apple is currently signing) without needing to spoof or restore my iphone. Alternatively if Apple is no longer signing a particular firmware then that SHSH cannot be saved anymore, even if the iphone is still on that firmware.

    You should be able to upgrade to the latest FW version and still be able to JB with that particular generation of iPT.
    This is not right. There is no official jailbreak released for 4.1 yet.
    Last edited by Simon; 2010-09-12 at 03:08 PM. Reason: Automerged Doublepost
    2010-09-12 03:08 PM
  17. Waleed786's Avatar
    I thought 2nd gen iPods can be jailbroken on any firmware since they have the old bootrom? That includes 4.1
    2010-09-12 03:15 PM
  18. Simon's Avatar
    any other ideas guys?
    First we need to determine what model itouch 2G you have. Does the model number begin with MC or MB? If MB then you can do the below:
    Download 3.1.2 firmware, restore to it and jailbreak with redsn0w 0.9.2 or blackra1n. Next use pwnage tool (mac) or sn0wbreeze (windows) to create a custom 4.0 firmware, put itouch in recovery then shift-click restore to that custom firmware.

    I thought 2nd gen iPods can be jailbroken on any firmware since they have the old bootrom? That includes 4.1
    MB model itouch 2G's can be jailbroken on any firmware, however redsn0w has not been updated yet to support 4.1 so using the version that was meant for 4.0 is going to cause issues. I am not sure what those issues are with an itouch but from what I have read with people using it on 4.1 iPhone 3G cydia is all screwed up and icons are missing.
    Last edited by Simon; 2010-09-12 at 03:18 PM. Reason: Automerged Doublepost
    2010-09-12 03:18 PM
  19. ddoolin's Avatar
    No it does not matter what firmware you are on when saving your SHSH.
    I misunderstood what you were saying before.

    This is not right. There is no official jailbreak released for 4.1 yet.
    2nd gen. non-MC models don't need a current release jailbreak as they don't need a signed SHSH. iPhone 1st gen, 3G, and iPod Touch 1st gen and 2G non-MC can be downgraded without an SHSH. No you can't jailbreak ON 4.1 but you can downgrade then do it (well you can but I wouldn't do use redsn0w on 4.1 yet personally). I should have specified.
    Last edited by ddoolin; 2010-09-12 at 03:23 PM.
    2010-09-12 03:21 PM
  20. Simon's Avatar
    You are right, iPhone 3G and iTouch 2G can be downgraded without SHSH, but only to pre 4.0 firmware. For 4.0 and up they also need SHSH to be able to restore. A way around this is using a custom 4.0 firmware but you need to be jailbroken with pwnage tool/sn0wbreeze/redsn0w/blackra1n first to be able to install a custom firmware.
    2010-09-12 03:29 PM
38 12
LINK TO POST COPIED TO CLIPBOARD