1. Tylerohwhat's Avatar
    Got an ipod touch 2G and im on 3.0 (i know, im lazy) And im trying to get to 3.1.3, i have "74.208.10.249 gs.apple.com" In my hosts file, but when i try to shift+restore it doesnt verify with apple. Gives the requested build cannot be completed error. Im not in DFU mode if that makes a difference. I just didnt know if going into DFU would work for sure or not, and it would suck to just stay on the same firmware and have to start from scratch. Any ideas?
    2010-09-11 09:03 PM
  2. Tylerohwhat's Avatar
    So do i need to put it in DFU? Sorry for posting again, 81 views but no replies
    2010-09-13 08:13 AM
  3. LamboFan's Avatar
    Doesn't work. Gotta get SHSH files for OS 3.x.x in order for it work.
    Otherwise, your out of luck.
    2010-09-15 04:42 AM
  4. Tylerohwhat's Avatar
    Alright, SHSH files for the OS im upgrading to, or the one im on? Or both?
    2010-09-15 04:53 AM
  5. Cer0's Avatar
    The one you are going to.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 04:57 AM
  6. Tylerohwhat's Avatar
    Hmm, this got trickier since i did it. What is my best bet right now?
    2010-09-15 04:59 AM
  7. Cer0's Avatar
    If you don't have SHSH on file then best bet would be wait for 4.1 jailbreak. But use tiny umbrela to get your SHSH for 4.1 at least.

    Could try these guides to see if they work.

    How to Jailbreak 4.0 iPhone 3G/iPod Touch 2g on OS X/Windows

    How to Jailbreak/Unlock 3.1.3 iPhone 3GS/3G/2G iPod Touch 2G/1G with sn0wbreeze Windows
    Last edited by Cer0; 2010-09-15 at 05:09 AM. Reason: Automerged Doublepost
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 05:09 AM
  8. Tylerohwhat's Avatar
    I have my current one on file, but how can i have 3.1.3 on file if ive never been on it? Sorry, little new to the firmware bit.
    2010-09-15 05:09 AM
  9. Cer0's Avatar
    When you hit the make my life easier button when you first jailbroke it gave Saurik your keys. From that point he has a script(I belive) that runs when new firmware is out to grab all the current firmware's SHSH for every key that he has stored.

    It is an automated process from the point that you hit the make my life easier button.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 05:12 AM
  10. Tylerohwhat's Avatar
    Right, and apple isnt signing 3.1.3 anymore so im pretty much screwed as far as 3.1.3?
    2010-09-15 05:14 AM
  11. Cer0's Avatar
    If it says that you have 3.1.3 on file then you can change your hosts file and go to that one.

    I thought the 2G didn't need it for the 3.x.x firmwares; only for 4.x. Put a # in front of 74.208.10.249 gs.apple.com and try again for 3.1.3.
    Last edited by Cer0; 2010-09-15 at 05:19 AM. Reason: Automerged Doublepost
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 05:18 AM
  12. Tylerohwhat's Avatar
    Darn i see my shsh on cydia says iOS 4.0, 4.1. so no way to get 3.1.3 on file unless i have a friend with it? Come to think of it, 4.0 is jailbreakable and it works with second gen, right?
    Last edited by Tylerohwhat; 2010-09-15 at 05:35 AM.
    2010-09-15 05:25 AM
  13. Cer0's Avatar
    The reason it says 4.0 and 4.0.1 is because your model shouldn't need SHSH for any firmware below 4.0. Apple started to sign firmware for the iPhone 3G and iPod 2G at 4.0. Anything below you should just be able to shift-click restore. Try like how I mentioned without the host change.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 05:57 AM
  14. Tylerohwhat's Avatar
    Okay well i tried restoring to 4.0 with that line still in hosts and it still tells me the device is eligible for the requested build? Is DFU mode 1000% necessary?
    2010-09-15 05:58 AM
  15. Cer0's Avatar
    Does the line have # in front of it or not? If so take the # off.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 06:03 AM
  16. Tylerohwhat's Avatar
    Tried it both ways. neither work. would updating to itunes 10 help?
    2010-09-15 06:06 AM
  17. Cer0's Avatar
    What version are you on?
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-09-15 06:13 AM
  18. Tylerohwhat's Avatar
    9.0.3.15
    2010-09-15 06:16 AM
LINK TO POST COPIED TO CLIPBOARD