1. ippone's Avatar
    Hi,

    I have a Touch 2G (MB) with 3.0 OS, never jailbroken. No SHSHs (for anything lower than 4.1).
    And I need to do a jailbreak, just now...
    I know that 3.x and 4.0.x OSes are not signed anymore (I'm getting 3194 errors when attempting to update and/or DFU restore to 3.1.3 ipsw).

    What should I do know? Is there any way to do a 3.1.3 jb with custom fw or something?
    I'll be fine with a 3.0 jailbreak but I would like to know if it's possible and safe with these 3194 errors?


    [I know the basics of DFU, shift+click recovery and I've got links to all ipsw files (Felixbruns) and iTunes releases (Theiphonewiki).]
    2010-09-16 12:06 AM
  2. moon#pie's Avatar
    I will help you with this, but first I want to know the sudden need to jailbreak.
    2010-09-16 12:09 AM
  3. ippone's Avatar
    2010-09-16 12:16 AM
  4. SnR's Avatar
    You don't need any SHSH for your device. You can use redsn0w, blackra1n, Spirit, jailbreakme, whatever tool you need for whatever firmware.

    For your device, you can use redsn0w to jailbreak most any firmware so far with custom FW.
    2010-09-16 01:17 AM
  5. i.Annie's Avatar
    You'll need SHSHs for going to 4.0.x. If you want 3.1.x then no SHSHs are necessary. Jailbreak with Jailbreakme for 3.1.2-4.0.1.
    2010-09-16 02:38 AM
  6. moon#pie's Avatar
    go to 3.1.2 and then jailbreak with redn0w.
    2010-09-16 04:17 AM
  7. ippone's Avatar
    Thanks for the response. The problem is that I don't can't "go to" 3.1.2 or 3.1.3. I'm getting a "3194" error: "This device isn't eligible for the requested build." after the "Verifying with Apple" step.
    The model is MB531LL (2nd generation 16GB) and i(Phone)OS version is 3.0 (7A341) and the iTunes version is 9.2.1.5.

    I've got "redsn0w-win_0.9.2" and 0.9.5b from the official redsn0w homepage.
    I've got 3.0.ipsw (along with 3.1.2 and 3.1.3) from Felixbruns.de.
    I've seen three youtube tutorials on 'redsn0w + 3.0'

    It's safe to use the redsn0w tool, since Apple doesn't sign/verify 3.x OSes anymore? I don't want to make any stupid mistakes
    Last edited by ippone; 2010-09-16 at 03:23 PM. Reason: Automerged Doublepost
    2010-09-16 03:23 PM
  8. moon#pie's Avatar
    2010-09-16 06:02 PM
  9. ippone's Avatar
    Yes. I downloaded all the 2nd gen ipsw files linked at iPod, iPhone and iPad Firmware Download "just in case".

    So what should I do now? Redsn0w? Using 3.0 or 3.1.2? I don't want to do any stupid mistakes.
    2010-09-16 06:33 PM
  10. moon#pie's Avatar
    what iOS are you running now?
    2010-09-16 09:08 PM
  11. ippone's Avatar
    I'm running "vanilla" OS3.0.
    2010-09-16 09:16 PM
  12. moon#pie's Avatar
    can you update to 3.1.3?
    2010-09-16 09:23 PM
  13. ippone's Avatar
    As I have stated before, I can't update to 3.1.3, I can't even shift+restore to 3.0 because I'm getting that 3194 error after "Verifying with Apple".
    2010-09-16 09:29 PM
LINK TO POST COPIED TO CLIPBOARD