1. ekkelon's Avatar
    Hello .... I have a problem with Cydia refresh. When I open Cydia I have some error after the Loading data this is the error image.
    I have try to delete Cydia cache but everytime when i make the refresh the same error in the same repo appear ... Solutions!? Thank you.

    2010-09-24 02:24 PM
  2. Gary smith's Avatar
    how do i fix this problem
    2010-09-24 02:37 PM
  3. ekkelon's Avatar
    @Gary_smith .... have you the same problem!?
    2010-09-24 02:41 PM
  4. nasnoy's Avatar
    i think its because u put a bad source a source doesnt work anymore your just going to have to deal with it i have it to i think everyone has it if you put a bad source URL hopefully someone finds a way to fix it
    2010-09-30 05:06 AM
  5. paradoxar's Avatar

    This is what has work for me in the past, you have to delete the source to remove the these type of errors

    The following is what you will need:
    1. An SSH program or iFunBox - Ex Cyberduck or Transmit for Mac and PuTTY or WinSCP for Windows
    2. WiFi or USB Connection for iFunBox
    3. Open SSH installed via Cydia if you want to use SSH apps.

    What to do?
    Open the SSH program and make sure you can see server:, User Name:, Password:, Path: and Port:.

    For server enter the IP address your iPhone is connected to.
    You can do this by opening the Settings app and going to the Wi-Fi section and then looking for the Wi-Fi you are connected to. Then click the arrow which shows the Wi-Fi info. Search for the IP Address e.g.

    The user name for your iPhone is root.
    The password is alpine.
    Leave the path blank.
    Make sure the port is 22.
    Select SCP as the File Protocol if applicable.
    Press Connect!

    Note: I personally use iFunBox since you can navigate to the file iPhone system like as Windows file explore.

    If you can not connect restart your iPhone, make sure you have Open SSH installed via Cydia and make sure you have entered the information correctly.

    Once connected go to the main directory and then navigate to /etc/apt/sources.list.d/. Search for Cydia.list and open it with a text editing program. You will find a list like the following sources:

    deb Index of /cydia ./
    deb http://homepage3.nifty.com/moyashi/cydia/ ./
    deb http://www.nightgamer.net/cydia/ ./
    deb http:d.mobilecinema.com/ ./

    After you have completed all this, launch Cydia and refresh your sources.
    If you get more source errors Read the error and look for the source(s) causing the problem.
    Then delete it from the Cydia list and save.
    E.g. If "http:d.mobilecinema.com/" was the problem like it is in the first picture above you would delete deb "http:d.mobilecinema.com/ ./" from the list.

    There are others methods I found by searching the internet, but this is the one that worked for me

    I hope this can help you..

    2010-09-30 05:32 AM
  6. Risingsun124's Avatar
    ^^^This, but I would add -First make sure the repo's you want to delete are not listed in your sources. If they are listed, I would delete them first before modifying the files on your phone. It may be as simple as just deleting the invalid sources.

    Either way it's an easy fix and I think everyone should know how to get at their files via SSH anyway.

    Good Luck
    2010-09-30 05:51 AM
  7. Julcello692's Avatar
    Some of the problem, like nasnoy said, is probably that the repo URLs you added just don't work anymore for various reasons.

    You can do what paradoxar does, but there is a much simpler way to fix bad repo URL's: Cyfix.

    Cyfix is simply a MobileTerminal extension that lets you hack into the root of your iDevice and eliminate bad repo URLs.

    1. Make sure you have MobileTerminal downloaded to your iDevice.
    2. When you have MobileTerminal, go to Cydia and download Cyfix.
    3. Open MobileTerminal.
    4. Type in "su root" and then press "return."
    5. Type in the password: alpine (note: the characters you will be typing will NOT show up on the screen) and press "return."
    6. Type "cyfix" and press "return."
    7. Type the bad repo URL (note: the http:// is added for you at the beginning, so don't type http:// again. Also remember to type the repo URL accurately and put a "/" at the end) and press "return."
    8. Wait for Cyfix to Erase, Eliminate, Exterminate, and Extirpate the bad URL.
    9. After this is complete, it will advise you to respring your device before launching Cydia for best results. Do this and your bad repo URL should no longer be a problem when you open Cydia after this process.

    Note: MobileTerminal and Cyfix can both be downloaded if you add the free xSellize repo to Cydia.

    I hope this was helpful!
    2010-10-02 07:19 AM