1. itouchi's Avatar
    Okay so as the title says I have no bluetooth,, well not completely..
    I recently purchased my iPod a few weeks ago and have tried jailbreaking with limera1n when I noticed that afterwards I could not find Bluetooth in the settings nor an icon on the statusbar yet Bluetooth in games works etc.
    Since then I have restored and jailbroken with greenpois0n,, same problem. It is gone again from inside the settings.
    When I respring or boot into safemode however it is found in the settings.
    So I was wondering if anyone else has this problem or if there is a fix for it. I would like to pair my Bluetooth headset and tether Internet from my friends iPhone without having to always switch into safemode.

    Any help is appreciated,,
    Thanks in advance
    iPhone Underground Themes and Wallpapers - http://ipug.net23.net/
    2010-10-25 10:32 AM
  2. korbyn8495's Avatar
    You've probably already tried this, but have you tried using the toggle in SBSettings to turn it on?
    Last edited by korbyn8495; 2010-10-27 at 02:52 AM.

    Follow me on Twitter for updates and freebie themes!
    2010-10-27 02:45 AM
  3. itouchi's Avatar
    You've probably already tried this, but have you tried using the toggle in SBSettings to turn it on?
    yep,,
    The bluetooth does work but nothing appears in the settings menus so I cant't connect to BT headsets etc.
    iPhone Underground Themes and Wallpapers - http://ipug.net23.net/
    2010-10-28 12:19 AM
  4. obedient.deviant's Avatar
    Have you taken a look at general.plist? When I did the jailbreak (also on iTouch 4G, iOS 4.1) it screwed up a couple of settings, BT included, and I had to rewrite the plist.

    FIRST OF ALL, BACK UP THE GENERAL.PLIST FILE!
    It's always a good idea!

    Find the section that pertains to Bluetooth (exact line may vary) and copy this code:

    <dict>
    <key>bundle</key>
    <string>BluetoothSettings</string>
    <key>isController</key>
    <false/>
    </dict>

    It should work. You know you have BT on a iTouch 4G so no need to muck it up with <key>requiredCapapabilities</key> and other jargon. No need to respring or reboot, should just be able to work. Worked for me, hope it solves your issue!

    *EDIT* just noticed that this does not restore the BT icon on the bar, just the menu under General settings
    Last edited by obedient.deviant; 2010-11-19 at 06:20 PM.
    2010-11-19 01:58 AM
  5. nyczwillz's Avatar
    or restore is your best friend.
    2010-11-19 02:47 PM
  6. obedient.deviant's Avatar
    Since then I have restored and jailbroken with greenpois0n,, same problem. It is gone again from inside the settings.
    So no, restore in this case is not your friend, unless you mean restore, back up general.plist, re-jailbreak, and then swap the general.plist file. Which is almost the same thing as what I said, though I didn't have a fresh general.plist file to copy from.
    2010-11-19 06:19 PM
  7. xSleader's Avatar
    it works perfectly for me! I thought my iPod was defective but it was not the case. Thank you for your help=D
    i edit the general.plist with iFile
    2011-03-31 09:31 PM
  8. Mphaker's Avatar
    Hi
    I have the same problem but a I'm a little confused on how to edit the plist. I'm at the bluetooth related part but what am I supposed to edit? My current part looks like this:
    <dict>
    <key>bundle</key>
    <string>BluetoothSettings</string>
    <key>isController</key>
    <false/>
    <key>requiredCapabilities</key>
    <array>
    <string>bluetooth</string>
    </array>
    </dict>
    That's the only BT related thing in there. THanks in advance
    2011-08-09 04:09 PM
LINK TO POST COPIED TO CLIPBOARD