1. Labertasche's Avatar

    I purchased TetherMe on my iPhone and iTether on my iPad as this was recommended to me as the best and most secure way (since it doesn't create a WEP hotspot) for tethering my iPhone 3G to my iPad.
    TetherMe on my iPhone worked great when testing it over USB and Bluetooth with my computer, but iTether on my iPad doesn't work.
    After I purchased it and ran it on my iPad it activated successfully but now every time I run it, I just get an error message:

    "Failed to connect to the tether daemon"

    Any ideas what I can do?

    2010-11-04 12:30 PM
  2. Ardenex's Avatar
    I had the same setup for a while now and worked perfectly until last night when I clicked upgrade in cydia. After the upgrade my iPad resprang and iTether not working anymore nether Cydia. Cydia actually crashing on open. It was definitely a bad update.
    Last edited by Ardenex; 2010-11-04 at 04:34 PM.
    2010-11-04 04:30 PM
  3. Labertasche's Avatar
    I did do a little bit more searching and found the solution:

    Anyone who just updated iTether 1.0.13 and erichooks 1.1.0 in Cydia will prob experience a problem with Cydia not loading upon their next restart. To solve the problem on your iPad on iPhone log into MobileTerminal and type:

    "dpkg --configure -a" (without the quotes)

    It appears that the erichooks shuts down before completing.

    My iPhone4 seemed to restart Cydia on its own after a few attempts and an apt-get update and apt-get clean command in MobileTerminal, but the same was not true with the iPad running 3.2.2.

    Let me know if you have any questions.
    Seems that this is a known problem, just hope they release an update soon, I also just noticed that Cydia didn't start anymore, I already saw myself doing a complete restore on my iPad

    Anyway, it works great now and I can tether from my iPhone to my iPad without buying that overpriced MyWi and have better security too
    2010-11-04 05:11 PM