User Tag List

  1. sandstorm77's Avatar
    I jailbroke my new iPad (WiFi) 16gb using redsn0w and everytime a try to load up an ebook it tells me there is something wrong and i need to restore using itunes. Anyone know of a fix for this?

    If i restore and dont jailbreak, the books work fine, so i know its the jailbreak causing the issue.
    2011-01-07 01:15 PM
  2. Simon's Avatar
    What firmware are you on and what version of redsnow are you using?
    2011-01-07 01:19 PM
  3. sandstorm77's Avatar
    latest firmware and redsnow 9.6b5
    2011-01-07 04:23 PM
  4. Simon's Avatar
    If you are on 4.2.1 try using the latest redsnow 0.9.6rc8 and see if that helps.
    2011-01-07 04:35 PM
  5. DaveiPhone's Avatar
    This is a known issue with the 4.2.1 jailbreak on newer devices. It doesn't happen on the old bootrom 3GS, but it does occur on both the iPhone 4 and the iPad. I'm not positive about the new bootrom 3GS or iPod Touch, but my guess is the problem happens on all newer devices.

    It only shows up when you try to open a Protected book, which may be free or purchased. Winnie the Pooh is an example of a free Protected book. Unprotected books and pdfs should open fine.

    I reported this to the redsn0w dev team a couple of weeks ago, and it has since been confirmed by many users. Unfortunately, I haven't seen any indication from the Dev-Team that there's a fix in works. I sure hope so.
    2011-01-07 05:53 PM
  6.'s Avatar
    I'm running on a jailbroken 4.2.1 Ipad and went to download the free ibook app form the itunes store and got a error message, that basically stated ibook can't understand the way the redsnow JB arranged certain files on the ipad.
    2011-01-07 06:21 PM
  7. Simon's Avatar
    Just tried it myself and Dave is right.
    2011-01-07 06:27 PM
  8. zoso10's Avatar
    I even had this problem with my iPhone4 on iOS 4.1
    2011-01-08 11:38 PM
  9. tsatryan's Avatar
    Same problem here, on both my iPhone4 and my iPad, both running 4.2.1, jailbroke with redsn0w 0.9.7b6
    2011-01-26 08:05 PM
  10. Simon's Avatar
    2011-01-26 08:20 PM
  11. tsatryan's Avatar
    It is a known issue
    I have searched everywhere - and can't find anything recent on any fix for this. Anyone know of anything? Or anything in the works to fix iBooks? I can -occasionally- get a purchased book to open... but not all the time, even on a book that did open.
    2011-01-29 04:33 AM
  12. Simon's Avatar
    Not too sure if a fix is being worked on or not.
    2011-01-29 12:36 PM
  13. Sherminator's Avatar
    Last edited by Sherminator; 2011-01-29 at 05:53 PM.
    2011-01-29 05:45 PM
  14. Fofer's Avatar
    Copying comments from a friend elsewhere:

    Presuming the 'free' books in the iBook store are DRMed, I just downloaded 'The Adventures of Sherlock Holmes' from the store and it opens fine.

    That post mentions an earlier version of redsn0w (0.9.6b5), whereas the untethered jailbreak is at 0.9.7b6 right now.
    Yes, the 'free' books in the iBook Store do have the same FairPlay DRM, so this is encouraging news. Anyone here try the new 0.9.7b6 untethered jailbreak?
    2011-01-29 06:10 PM
  15. Sherminator's Avatar
    The 0.9.7 betas don't have to untethered if you don't have access to the beta firmware or it's SHSH. It can work as a tethered one.
    Last edited by Sherminator; 2011-01-29 at 06:32 PM.
    2011-01-29 06:13 PM
  16. Fofer's Avatar
    Sherminator, wassa matta, cat got your tongue?
    2011-01-29 06:31 PM
  17. Sherminator's Avatar
    got pulled away before I could make the post make sense.
    2011-01-29 06:33 PM
  18. Fofer's Avatar
    More info copied from a friend's note:

    No, that's not true, it's not fixed in 0.9.7b6 either. There are SOME free books are also protected, but "Adventures of Sherlock Holmes" isn't one of them. "Winnie the Pooh" is a good test example. It's free AND protected. Have your friend try that, and I have no doubt it will fail.

    I was actually the one to first report the bug, and and as near as I can tell, it's not even being addressed. It doesn't have anything to do with untethering, as it shows up immediately after jailbreaking, even if you're still tethered. At that point, if you you have a device that will boot untethered but without Cydia or jailbreak advantages (like the iPad), you can boot untethered, and iBooks will work again. But if you do a tethered boot, it will fail. And if you do the Monte untether, it will fail without recourse, because you can no longer do a clean boot.

    This applies to all the jailbreaks on 4.2.1 as far as I can tell, including the most recent beta, but only on the newest devices (iPad, iPhone 4, probably 3GS with the new bootroom, though I don't have one of those to test).

    There are a ton of replies to my original and subsequent reports on the DevTeam blog confirming the issue, but not a single response from a dev-team member anywhere indicating that it's even on their radar, so I'm not terribly hopeful that it will be fixed soon.
    2011-01-30 07:50 PM
  19. Fofer's Avatar
    DRM'ed books don't load in iBooks with the new greenp0ison jailbreak, either.

    I sure do hope this issue gets more widespread attention and the jailbreak devs figure out how to fix this.

    Users are able to pay for books in the iBook Store only to find out later, they won't open. That's not good. I'm surprised none of the "how to's" about jailbreaking 4.2.1 are making mention of this pretty big bug.
    2011-02-08 07:25 PM
  20. DaveiPhone's Avatar
    It looks like comex is finally looking into this:

    Greenpois0n breaking DRM books in iBooks - JBQA
    2011-02-08 08:10 PM
34 12