User Tag List

  1. rosepeing's Avatar
    i recently upgraded to version 4.5.5,the default version of my ipad 2 is 4.3.3,im so desperate on having it jailbroken then i heard that my current version which is 4.5.5 cant be jail breaked.I really regret upgrading it!Anyway is there any possibility that i could jailbreak my ipad 2 with this version of software?if so there is,cant anyone teach me how?thanks a lot! your participation is very much appreciated.
    2011-09-20 06:18 PM
  2. RRoD420's Avatar
    The latest is 4.3.5 which is what you updated to. Did you ever have it jailbroken at 4.3.3?
    2011-09-20 07:54 PM
  3. dark-soul085's Avatar
    You need ur shsh blobs for ios 4.3.3 to downgrade ur ipad , the only available jailbreak for ipad 2 is for ios 4.3.3 using jailbreakme.com , if you dont have the shsh blobs and u never jailbroke ur ipad before updating then ur stuck untill the release of ios 5 .

    If you jailbroke ur ipad b4 may be cydia saved them for u and you can get them by downloading the latest tinyumbrella and use " save shsh blobs " option.
    2011-09-23 04:06 AM
  4. iYeow's Avatar
    +1, you need 4.3.3 shsh blob for downgrade.
    2011-09-23 08:14 PM
LINK TO POST COPIED TO CLIPBOARD