1. Parksy87's Avatar
    Hi, i am having a very strange problem with an ipod touch 2nd gen 32gb it currently has 2.2.1 on it because it wont update/restore past this even though itune says 4.2.1 is avaiable i have tried in dfu and recovery mode and recieve errors 14 and 1604 i have even tried ios 3 but no joy, tiny umbrella shows model number : mb533bt/a - invalid all firmware updates seem to fail and then i have to restore 2.2.1 before i can use it again, anyone have any ideas?
    many thanks

    2011-09-24 04:03 PM
  2. computer180's Avatar
    Update iTunes?
    2011-09-25 10:16 AM
  3. Estonio's Avatar
    Yes with ITunes, I have the same problem, When the update file is downloaded and try to process the file there is an error window saying that the time waiting for the connection was exceeded..
    2011-09-28 10:44 PM
  4. Parksy87's Avatar
    I have the newest version of itunes, have tried multiple cables, and laptops/pc's running windows xp vista and 7
    2011-10-07 01:16 AM
  5. i.Annie's Avatar
    Open TinyUmbrella, go to Advanced Options, uncheck the box to "point to cydia on exit" then close TU. Open iTunes (don't have it opened while you do the TU step) and hit upgrade.
    2011-10-07 01:17 AM
  6. Parksy87's Avatar
    I have tried to upgrade it on a laptop that never had itunes on it before and has never had tiny umbrella on it either and i still got the error
    2011-10-07 03:25 PM
  7. computer180's Avatar
    put your iPod in DFU mode instead of Recovery mode...
    2011-10-07 03:52 PM
  8. i.Annie's Avatar
    Are you using a custom firmware. Or just hitting upgrade in iTunes.
    2011-10-07 04:52 PM
  9. Parksy87's Avatar
    I have tried recovery mode and dfu mode, i am just hitting upgrade, i cant remember wether i have tried cooking a custom 4.2.1 i have tried that many different firmwares iv lost track
    2011-10-07 05:57 PM
  10. i.Annie's Avatar
    You should just hit upgrade and not use a custom fw to see what it does
    2011-10-07 06:34 PM
  11. computer180's Avatar
    4.2.1? o.0 you should be ugprading to 4.3.5. Apple's stopped signing 4.2.1-4.3.3 agess ago.
    2011-10-08 03:40 AM
  12. i.Annie's Avatar
    2G iPT only goes up to 4.2.1. Apple stills signs 4.2.1 for iPT 2G and iPhone 3G.
    2011-10-08 03:46 AM
  13. Jabbacks's Avatar
    Just uploaded 4.2.1 to ipod touch 2g using ipsw from funkyspacemonkey with iTunes "Restore". Put phone in DFU mode, open TinyUmbrella and checked "point to cydia on exit". Open iTunes, shift-restore and select ipsw 4.2.1. All went well. Then jb with redsn0w_win_0.9.6rc8.

    It's ok now. Thing is I cannot install themes. Tried winterboard but it just exits after select!
    2011-10-08 05:14 AM
  14. i.Annie's Avatar
    Restore and redo the jb.
    2011-10-08 07:47 AM
  15. Jabbacks's Avatar
    Restore and redo the jb.
    Sorry, you talkin to meh?
    2011-10-08 08:28 AM
  16. i.Annie's Avatar
    Yup. If you're WB is crashing
    2011-10-08 04:51 PM
  17. Parksy87's Avatar
    Jabbacks did u already have shsh saved from 4.2.1 before?

    I get error 1604 or error 14 after it has hung on preparing ipod for restore have tried in recovery mode dfu mode and normal mode while it is running on 2.2.1 still get the same errors
    Last edited by Parksy87; 2011-10-08 at 05:30 PM.
    2011-10-08 05:27 PM
  18. i.Annie's Avatar
    You don't need SHSHs for 4.2.1 on an iPT 2G, that's the highest fw version for that device so Apple still signs it.

    The issue isn't within whether you're using SHSHs or not.

    Edit: I asked you if you're using a custom fw bc error 14 is a cFW issue where you're not setting your device into pwned dfu. The same goes with error 1600's.

    So consider just upgrading to stock 4.2.1 or at least putting your device into pwned dfu mode before restoring to cFW.

    Also, do the TU steps I told you to before doing this. If it is pointing at Cydia's server and you're trying to get to 4.2.1 which is a currently signed fw for that device, it'll likely error out.
    Last edited by i.Annie; 2011-10-08 at 05:58 PM.
    2011-10-08 05:56 PM
  19. Parksy87's Avatar
    I am trying to upgrade to stock 4.2.1 i have tried dfu and recovery mode and also while it was running 2.2.1 i have not got the host file edited in any way or tinyumbrella running and i ge error 14 and 1604
    2011-10-08 09:02 PM
  20. i.Annie's Avatar
    TinyUmbrella doesn't have to be open or running to point the restore to Cydia's servers. Ensure under Advanced Options that the box to point to Cydia on exit is not checked.

    According iPhone error wiki:

    Error 14
    Custom firmware update fail (PwnageTool until 4.0.1). You have to restore the device with a custom firmware. Update to a custom firmware isn't working. Device isn't bootable. 2
    USB Problem. Check the USB connection and try other direct ports or maybe the USB cable is an older one. Device isn't bootable.
    You're trying to 'update' to a beta firmware instead of performing a restore. Device is still bootable if you kick it out of recovery mode.
    Rebooting your Mac or PC may resolve this issue.

    Error 1604
    Device was not pwned (signature checks were not blocked). Custom firmware can't be restored. Can also happen when there's a problem with the IPSW.
    2011-10-08 10:20 PM
24 12