User Tag List

  1. Chad711's Avatar
    Topic states it all, Never had a ipad so not sure if I can JB 4.3.5 or 5.0 currently? I'd be fine if it was a tethered jb...

    thanks
    2011-10-31 01:38 AM
  2. Simon's Avatar
    Only jailbreak for iPad 2 right now requires 4.3.3 firmware.
    2011-10-31 01:39 AM
  3. Chad711's Avatar
    Did they, do they ever have tethered jailbreaks for iPads or is that just a iPhone thing?
    2011-10-31 02:51 AM
  4. Simon's Avatar
    For the first iPad there is a tethered jailbreak for newer firmwares. For iPad 2 so far there has only been the one jailbreak on 4.3.3.
    2011-10-31 03:00 AM
  5. emerica6708's Avatar
    If you are going to get a used one look on eBay for one with SHSH blobs saved for 4.3.3, craigslist usually has a couple with blobs too. Just make sure it's wifi only, SHSH blobs can only be used to downgrade if it's wifi only. So if you want a 3G iPad 2 find one that is already on 4.3.3 and just hope nothing happens that will make you have to restore, if you don't want 3G just make sure it has blobs saved for 4.3.3 and you can downgrade/restore if needed.
    2011-10-31 03:51 AM
LINK TO POST COPIED TO CLIPBOARD