1. King_O_Hill's Avatar
    Try this:

    Place both themes into one theme folder.

    Then create a new LockBackground.html file with the code that I have below.

    Code:
    <html>
    	<head>
    
    	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
    
    	</head>
    
    	<body onLoad="onLoad();">
    
    <object data="BaSalt/LockBackground.html"  type="text/html" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:1; display:;"/> </object> 
    <object data="e6/LockBackground.html"  type="text/html" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:2; display:;"/> </object> 
    
    	</body>
    </html>
    Look at this:

    <object data="BaSalt/LockBackground.html"

    Where I have "BaSalt", you need to edit to the actual folder name. Do the same for "e6"

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2013-04-29 09:04 PM
  2. signori's Avatar
    Try this:

    Place both themes into one theme folder.

    Then create a new LockBackground.html file with the code that I have below.

    Code:
    <html>
    	<head>
    
    	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
    
    	</head>
    
    	<body onLoad="onLoad();">
    
    <object data="BaSalt/LockBackground.html"  type="text/html" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:1; display:;"/> </object> 
    <object data="e6/LockBackground.html"  type="text/html" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:2; display:;"/> </object> 
    
    	</body>
    </html>
    Look at this:

    <object data="BaSalt/LockBackground.html"

    Where I have "BaSalt", you need to edit to the actual folder name. Do the same for "e6"
    I am going to try it now. But what do I do for the Config.js files. Do I add them into one Config.js. Thanks.

    Update:
    I did what you said put both theme folders into one folder and made a LockBackground.html file. I put the exact folder names like you said. Applied it with winterboard. So the E6 lockscreen shows but not the Basalt theme. Well when the lock screen is loading the basalt overlay shows but then disappears.
    Last edited by signori; 2013-04-29 at 09:56 PM.
    2013-04-29 09:33 PM
  3. King_O_Hill's Avatar
    I am going to try it now. But what do I do for the Config.js files. Do I add them into one Config.js. Thanks.
    No, leave all as is.

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2013-04-29 09:55 PM
  4. NewD's Avatar
    No, leave all as is.
    Won't he need to change some Z-index levels of the 3? And what about commonly named image folders? Will he have to change any names of those folders that are named the same thing and then change the calls in the HTML files themselves?

    Love this idea, King! Thanks for your help!
    2013-04-30 12:50 AM
  5. King_O_Hill's Avatar
    Won't he need to change some Z-index levels of the 3? And what about commonly named image folders? Will he have to change any names of those folders that are named the same thing and then change the calls in the HTML files themselves?

    Love this idea, King! Thanks for your help!
    No, that's why you put the entire folder into your new theme folder. Notice that the directory path is different for each HTML file.

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2013-04-30 02:29 AM
  6. NewD's Avatar
    No, that's why you put the entire folder into your new theme folder. Notice that the directory path is different for each HTML file.
    Ah of course. What about z-index issues, though? I see you mark one z-index:1 and one z-index: 2 in the two object data calls - do those z-indexes supercede the z-index values deeper in the other LS widgets?
    Last edited by NewD; 2013-04-30 at 03:29 AM.
    2013-04-30 03:27 AM
  7. King_O_Hill's Avatar
    No, they may need to be adjusted. Also any full page images may need to be eliminated. Still though, fairly simple.

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2013-04-30 03:52 AM
  8. NewD's Avatar
    No, they may need to be adjusted. Also any full page images may need to be eliminated. Still though, fairly simple.
    Yes, this has given me a method for looking, in TacoHTML Edit, at MJ's Timed Walls with Ian's UniAW6.1 running on top of it - I think... Now...
    1) ..will the Wallpaper.html designation of MJ's Timed Walls and Widget.html designation of UniAW make any difference in the piggyback method? I think the difference between Wallpaper and Widget is only needed for a distinction in WinterBoard itself where Widget.html runs OVER any Wallpaper.htmls - right? That's what my emerging 'coding chops mind' tell me.. Am I on?
    2) For the purpose of running two htmls with each other in a LivePreview mode in Taco - I could call those 2 distinct html files anything I wanted - right?

    And MJ's walls are set to z-index -9999 - so I think that gets me clear of any conflicting z-indexes. Well there's nothing like experimenting. Off to try now..

    Thanks for the great tutorial. I knew piggyback's application for using WallpaperJPEGifier as well as its application to 'box up' in a container widget elements to move them up or down all at once (as in prepping an SB Widget to iWidget conversion) but I never thought of two object datas in one folder pointing to two different folders. Piggyback is the 'gift that just keeps giving' to the wannabe new coder. LOL!!

    Thanks, sir!
    Grant
    2013-04-30 04:11 AM
  9. NewD's Avatar
    Brian,
    I had such fun tonight testing all this. I was able to get almost all my elements (minus icons) on a single screen in LivePreview. Simply by adding more and more piggyback obj data lines in a single html.

    And I DID confirm that the z-index values of the call in my created 'Main.html', piggyback file, DO override other z-index entries in the individual widget folders and .css z-index values themselves. UniAW6, for example, uses z-indexes between 0 and 100 for all elements. But even when I set the piggyback z-index for UniAW to 300 and MJ's timed walls to 299, the UniAW animations were on TOP of the timed walls in the other folder. If the z-index numbers nested in the subfolder governed UniAW - then the animations should have been hidden with MJ's walls set to 299. So that's REALLY good to have learned.

    Thanks for the folder in folder trick. SO much easier than renaming duplicate Images folders. LOL!

    Heading to bed now. Up WAAAY too late tonight with all this nonsense.. My addiction.. LOL!
    Last edited by NewD; 2013-04-30 at 08:15 AM.
    2013-04-30 08:12 AM
  10. MamaJaay's Avatar
    Side note:
    Calling more and more HTML's and different CSS and config files is going to eat through ram.

    (That's how smash started)
    2013-04-30 01:05 PM
  11. NewD's Avatar
    Side note:
    Calling more and more HTML's and different CSS and config files is going to eat through ram.

    (That's how smash started)
    This was only for testing purposes on my computer, MJ. And 3 of the elements I made the calls for were non weather iWidgets. . And the first was your Timed walls which aren't ram intensive at all. I was just looking for a way, thru live preview mode in TacoHtmlEdit on my Mac, to see all I run on my SB.
    2013-04-30 02:00 PM
  12. Dalvar3's Avatar
    Has someone found the issue to the location update without respringing? I've reset all settings with no success. Thanks

    The fix that was found was to go to the settings app and under "general/reset" apply "reset network settings".
    Did u find the solution for this?

    Ok done.
    I hope now it will be updated each time I travel...
    Thanks
    Last edited by Dalvar3; 2013-05-07 at 02:31 AM.
    2013-05-07 02:27 AM
  13. NewD's Avatar
    Has someone found the issue to the location update without respringing? I've reset all settings with no success. Thanks



    Did u find the solution for this?
    For the vast majority of us who were having the problem, the "reset all settings" made the problem go away. But there were still a few people experiencing what you're experiencing. The current theory is that there's some conflict with another tweak you're using. Have you tried turning off all tweaks and seeing if The update location works after that? Add the new Cydia Source: http://exile90software.com/cydia/ . And then download a tweak called iCleanerPro. In it there's a place where you can turn off all mobile substrates. Leave the switches next to the things called "daemons" all on. Don't change any of those switches. But Turn off all mobile substrate switches except the one for winterboard And myLocation. Then test the phone's ability to update your location with all those other things turned off. If it works, then that proves that one of the other tweaks you are using is interfering with the widget getting the updated location information. The only way to test for which one is causing the problem is to go back into iCleaner and turn each of those mobile substrate switches on one by one and retest the phone's ability to update the widget after each new switch you turn back on. It's a long and painful process. But it's the only way to find out the problem. However, If the phone does not update even with all the mobile substrates switches turned off, then there's some other problem that is unique to your phone. For most of us it is working fine.
    Last edited by NewD; 2013-05-07 at 01:10 PM.
    2013-05-07 03:25 AM
  14. Dalvar3's Avatar
    Ouch, that'll be painful but i'll try it. Thanks.

    <can someone pls confirm if the fact of not having "on" apply hierarchically on /var/mobile/Documents affects myLocation.txt to be pulled or something?.

    I cannot modify that setup>

    For the vast majority of us who were having the problem, the "reset all settings" made the problem go away. But there were still a few people experiencing what you're experiencing. The current theory is that there's some conflict with another tweak you're using. Have you tried turning off all tweaks and seeing if The update location works after that? Add the new Cydia Source: http://exile90software.com/cydia/ . And then download a tweak called iCleanerPro. In it there's a place where you can turn off all mobile substrates. Leave the switches next to the things called "daemons" all on. Don't change any of those switches. But Turn off all mobile substrate switches except the one for winterboard And myLocation. Then test the phone's ability to update your location with all those other things turned off. If it works, then that proves that one of the other tweaks you are using is interfering with the widget getting the updated location information. The only way to test for which one is causing the problem is to go back into iCleaner and turn each of those mobile substrate switches on one by one and retest the phone's ability to update the widget after each new switch you turn back on. It's a long and painful process. But it's the only way to find out the problem. If the phone does not update even with all the mobile substrates which is turned off, then there's some other problem that is unique to your phone. For most of us it is working fine.
    Last edited by Dalvar3; 2013-05-07 at 08:30 PM.
    2013-05-07 07:04 AM
  15. donkeylarry's Avatar
    Hey ALL!!! Would anyone we willing to take a look and fix the GPS weather on this LS?!? It's my favorite thing on my phone and I have tried everything I can within my limited capability. It hasn't worked since the notorious blip several weeks back.

    You would become my favorite person in the world if you can fix this!!! Thanks so much in advance!!!

    http://www.dropbox.com/sh/97v6xupjvr43j15/UcV34iPCpv
    2013-05-10 10:45 PM
  16. GUNNY29's Avatar
    Hey ALL!!! Would anyone we willing to take a look and fix the GPS weather on this LS?!? It's my favorite thing on my phone and I have tried everything I can within my limited capability. It hasn't worked since the notorious blip several weeks back.

    You would become my favorite person in the world if you can fix this!!! Thanks so much in advance!!!

    http://www.dropbox.com/sh/97v6xupjvr43j15/UcV34iPCpv
    Pm NateD it is his widget by looks of it
    Click My Sig For my auros Mods
    2013-05-10 11:08 PM
  17. RKO1195's Avatar
    Hey ALL!!! Would anyone we willing to take a look and fix the GPS weather on this LS?!? It's my favorite thing on my phone and I have tried everything I can within my limited capability. It hasn't worked since the notorious blip several weeks back.

    You would become my favorite person in the world if you can fix this!!! Thanks so much in advance!!!

    http://www.dropbox.com/sh/97v6xupjvr43j15/UcV34iPCpv


    Well you would need to zip it up so we could see what you got it looks like you got two widgets in that folder
    2013-05-11 12:16 AM
  18. donkeylarry's Avatar
    Thanks! I'll try to zip this tomorrow.
    2013-05-13 07:05 AM
  19. donkeylarry's Avatar
    Ok here is the link to the zip folder which contains the LS. ANY HELP WOULD BE GREATLY APPRECIATED!!!

    https://www.dropbox.com/s/f981yjthay9zd9b/NateDMios.zip

    And this is an image of the LS.

    GPS Based HTML Lockscreen Weather Theme-ls-photo.png
    2013-05-15 05:45 PM
  20. anneka234b's Avatar
    I installed the new MyLocation following your instructions below. It was working fine, but then it stopped updating. I tried to reinstall the repo but the link is not working on Cydia. Could you please check it?

    Thanks

    MyLocation App update for 5.1.1 - 6.1.2 from bushe! Incase you are having problems, this app is working fine. You may need an updated location.js file. If it has been updated, and still not updating go to settings/general/reset and reset all settings, this will not affect your JB!
    Download these Instructions - Instructions!
    To install the MyLocation app, just add my repo and install it! - http://cydia.myrepospace.com/kohidevice/:

    I installed the new MyLocation following your instructions below. It was working fine, but then it stopped updating. I tried to reinstall the repo but the link is not working on Cydia. Could you please check it?

    Thanks

    MyLocation App update for 5.1.1 - 6.1.2 from bushe! Incase you are having problems, this app is working fine. You may need an updated location.js file. If it has been updated, and still not updating go to settings/general/reset and reset all settings, this will not affect your JB!
    Download these Instructions - Instructions!
    To install the MyLocation app, just add my repo and install it! - http://cydia.myrepospace.com/kohidevice/:
    2013-05-21 03:13 AM
LINK TO POST COPIED TO CLIPBOARD