1. CanOfWorms's Avatar
    I have tried at length to upgrade my iPad 2 from its current iOS of 4.3.3 to 5.0.1 with no luck. I get very close but fails when Apple tells me 5.0.1 is an invalid image. I now understand Apple regulates these iOS updates to only allow the latest versions to be used.

    I need 5.0.1 as there is no Jailbreak for iPad 2 A5 iOS 5.1 and I dont see it ever happening. I am missing out on some of the AirPlay features, iCloud stuff, etc.

    Regardles of how complicated the process may be can anyone give me the tools the get my lovley iPad upgraded to v.5.0.1?

    Good stuff, thanks in advance for the help!
    2012-05-06 01:27 PM
  2. 2k1's Avatar
    Ya need the 5.0.1 blobs to upgrade to that version. If ya don't have them ya can't upgrade.
    2012-05-06 01:36 PM
  3. CanOfWorms's Avatar
    Ok right. I read about these. They seem like some type of backup that is standard for the device. Anyone have the blobs to send me??
    Device ID: iPad2,2
    Model: K94AP
    CPU: ARM Cortex-A9 Apple A5
    iOS: 4.3.3
    System Build: 8J2
    Kernel: Darwin 11.0.0
    Kernel Build: 199506
    Provider: At&t

    Cydia says I can upgrade to 5.0.1 and it has the blobs.. reading on it now.
    2012-05-06 01:42 PM
  4. 2k1's Avatar
    Blobs only can be used for that iPhone or iPad. You can download tinyumbrella and see if ya have the blobs for 5.0.1
    2012-05-06 01:51 PM
  5. CanOfWorms's Avatar
    TU tells me it has SHSH for 5.0.1 - is that the same as a blob? Thanks for your help 2k1!
    2012-05-06 01:53 PM
  6. 2k1's Avatar
    Yep sure is
    2012-05-06 02:01 PM
  7. CanOfWorms's Avatar
    Is there a particular set of upgrade instructions/step-by-step that you prefer? The last time I tried this I was using the how to on Redmondpie I belive.
    2012-05-06 02:07 PM
  8. 2k1's Avatar
    On the download section here you will have to download the 5.0.1 firmware for ya iPad an then do this.
    Go to Redsn0w, click "extras", then click "SHSH", then click "stitch".
    Click the ipsw button and point to the ipsw.
    Under "Blobs", click the 'Local" button and point it to your 5.0.1 SHSH (should be in "user/shsh")
    Then enter pwned DFU with redsn0w and restore to the custom stitched firmware it just made.
    Ya ipsw is what ya gonna download on the forum.
    2012-05-06 02:15 PM
  9. CanOfWorms's Avatar
    ZIP file downloaded and extracted, no IPSW only DMG. Rename ZIP to IPSW and Redsn0w complains "stitching for this IPSW isnt currently available".

    How can I make a viable IPSW?

    redsn0w's Verify passes, "all 19 blobs verified, APTicket is present and valid"

    redsn0w ver. 0.9.10b8b
    TinyUmbrella v5.10.08
    Hosts file updated to Cydia

    I also can not stitch in DFU mode, with TU server started and host file modified. The firmware i downloaded is, iPad2,2_5.0.1_9A405_Restore.ipsw

    Do i need an older version of redsn0w?

    installed iTunes version =
    Last edited by CanOfWorms; 2012-05-06 at 03:39 PM.
    2012-05-06 03:08 PM
  10. CanOfWorms's Avatar
    Anyone have any ideas why i get "stitching for this IPSW isnt currently available"?
    2012-05-09 03:55 AM
  11. Imahottguy's Avatar
    Stitching only works on A4 or older devices. Currently there is no way to make a signed firmware for iPad 2 or 3 or iPhone 4S. Unfortunately, if you are not on 5.0.1 right now you are SOL until the next jailbreak comes out or when iH8snow releases a tool that allows A5 devices to downgrade. Having the blobs may be useful at some point in the future. For now, we just have to wait and see what happens.
    And it will be like a taco inside a taco within a Taco Bell that's inside a KFC that's within a mall that's inside your dream!
    2012-05-09 10:41 AM
  12. CanOfWorms's Avatar
    SOL, aye. Thanks.
    2012-05-09 11:56 AM
  13. Erbenix's Avatar
    U should be able to do it now.
    2012-05-13 09:23 PM