1. Dhfhy's Avatar
    Alright, Sorry for the confusing title. I had no clue how to word this. So anyways, I changed the colors of the SMS bubbles and found a carbon fiber background, re-sized it to fit portrait and landscape. But when I send a MMS message the original white background still shows. I went through the Chatkit files, and the bubble for images has a transparent BG.

    Can someone please tell me how to fix this, if there is a fix?

    Example of my problem in attachments.
    Attached Thumbnails MMS Bubble, Problems with SMS Background-img_0224.png  
    2012-06-01 10:16 AM
  2. Jato_BZ's Avatar
    I have read this before. Apparently it is an issue with WinterBoard unfortunately ...
    Twitter ID: @Jato_BZ
    .artwork Assassin / Emoji Extractor
    2012-06-02 12:08 AM
  3. Dhfhy's Avatar
    Aweee Well hopefully it gets fixed
    2012-06-02 12:15 AM
  4. Jato_BZ's Avatar
    I'm not sure, it has been like that for ages. Apparently MMS is buggy? Or how it all works. I'm no expert but just what I have read. Yuh it is a shame. I guess tho at the same time we are lucky we can run a background at all.
    Twitter ID: @Jato_BZ
    .artwork Assassin / Emoji Extractor
    2012-06-02 12:18 AM
  5. Dhfhy's Avatar
    Oh, I didn't have the problem until IOS 5.1 :/ But thanks anyways.
    2012-06-02 12:22 AM
  6. cyberjunkyfreak's Avatar
    Alright, Sorry for the confusing title. I had no clue how to word this. So anyways, I changed the colors of the SMS bubbles and found a carbon fiber background, re-sized it to fit portrait and landscape. But when I send a MMS message the original white background still shows. I went through the Chatkit files, and the bubble for images has a transparent BG.

    Can someone please tell me how to fix this, if there is a fix?

    Example of my problem in attachments.
    sorry I don't know of a fix but was hoping maybe you could help me? I have iPhone 4 w/ iOS 5.1.1 jb and applied a custom SMSbackground@2x.png with winterboard... the problem is my chat bubbles are now "squished"... they just look like a line thru the text. Any ideas what I'm doing wrong? Thanks for any advice!
    2012-06-12 02:01 AM
  7. Jato_BZ's Avatar
    SMSBackground.png no "@2x" in the file name. Try this and respring, mine is showing fine and I'm on 5.1.1 iPhone 4S
    Twitter ID: @Jato_BZ
    .artwork Assassin / Emoji Extractor
    2012-06-12 04:16 AM
  8. cyberjunkyfreak's Avatar
    Thank you Jato, I ended up deleting the Balloon_1@2x.png, Balloon_2@2x.png and Balloon_Blue@2x.png from the /System/Library/PrivateFrameworks/ChatKit.framework directory and then re-added new ones and that seemed to fix the issue. I keep the SMSbackground@2x.png in /var/stash/Themes.xxx/SMS Wallpaper directory without any problem. The background image is 960 x 960 for nice fit both portrait and landscape with no white space. Not sure if the original problem was a permissions issue on the balloon files or what... strange that the balloons worked fine with the stock background (both before and after applying the custom background).

    Something else I learned is while the Balloon_2@2x.png is for all incoming texts... the Balloon_Blue@2x.png balloon is for sending to iMessage recipients and the Balloon_1@2x.png is for sending to all other SMS recipients (I just use same image for both files). This may be coming knowledge for some of you but it was new to me so figured I'd share if anybody else out there is interested. This issue kicked my @$$ for the better part of today... however it was worth the challenge as I find the end result to be rewarding.

    Here's the end result...

    MMS Bubble, Problems with SMS Background-imessage.jpg



    Andy sorry Dhfhy for not having anything to add to your original question... I will see if I can find something on that and report back if I have good news.
    2012-06-12 05:04 AM
LINK TO POST COPIED TO CLIPBOARD