1. jakx's Avatar
    I'm not sure if it can be done but for me it is a valuable question to ask. My ipod touch is currently running IOS 4.1 (because it requires no apple signature) and is jailbroken. I'm wondering if there is a way to install 4.3 (4.3.1 or 4.3.3 or 4.3.5)? I have tried and been unsuccessful because the need of either shsh blobs (and I'm not even sure what these are or where to obtain them) or an apple signature. If this information is needed I'm running windows 7 64x. Thanks in advance for any help you can provide me!
    2012-08-01 07:12 AM
  2. H4CK3R's Avatar
    I have no clue how I can explain it to you in a nutshell, but their basic job is to verify with the Apple servers. Then if Apple still signs it, it'll sign the IPSW. If not, it won't sign it. But, unless you have blobs on your iPod, nope. You can check if you have the blobs by going into Cydia and on the home page, it will say what SHSH you have in the top in green text. For example, I have SHSH blobs for iOS 4.3.3, 4.3.4, 4.3.5, 5.0.1, 5.1, 5.1.1. If you have 4.3.3 in there some where, it's your lucky day. Just download the latest version of Redsn0w (it can be downloaded here: blog.iphone-dev.org) after downloading it, right click it and hit "Run as Administrator" and then let it open. From there, go into the "Extras" tab and hit the "SHSH blobs" button and then the "Fetch" button. Redsn0w will direct you what to do and then you'll have your SHSH blobs on your PC. After this, you must download a 4.3.3 IPSW (these can be found in the downloads section of this site) and then you can go to Extras > SHSH blobs > Stitch and then select the IPSW and blobs and let Redsn0w do it's thing. After this you can restore to the IPSW you just made in iTunes by doing a shift + restore and selecting the IPSW. From there let iTunes do it's thing
    2012-08-01 12:45 PM
  3. jakx's Avatar
    Thanks for your reply. I pretty much understand what you are saying. However, when I get to the stitch part (that is stitching 4.3 with the newly created file) the file that redsnow created I get an error message: Those blobs don’t appear to match the IPSW build.
    My guess is that when I extracted the blobs it only extracted the blobs for my current firmware version (4.1) but I could be totally wrong on that. My cydia does show that I have shsh for both 4.3.3 and 4.3.5, but how do I choose which ones I can extract? Or maybe I'm going about this the wrong way……PLEASE HELP…….
    2012-08-01 04:13 PM
  4. jakx's Avatar
    At first your method didn’t work, but I used a cydia app called ishshit (I think) to back up specific blobs (4.3.3) and email them to my computer. Then I used that file and stitched it to the ios 4.3.3 and it worked thanks for all your help!
    2012-08-01 06:06 PM
  5. H4CK3R's Avatar
    No problem Glad it worked
    2012-08-01 08:11 PM